Closed Bug 1244069 Opened 4 years ago Closed 4 years ago

Fix configure.in minimum requirement to NSS 3.21

Categories

(Firefox Build System :: General, defect)

45 Branch
defect
Not set

Tracking

(firefox44 fixed, firefox45 fixed, firefox46 fixed, relnote-firefox 44+)

RESOLVED FIXED
Tracking Status
firefox44 --- fixed
firefox45 --- fixed
firefox46 --- fixed
relnote-firefox --- 44+

People

(Reporter: KaiE, Assigned: KaiE)

References

Details

Attachments

(1 file)

In bug 1211568, we forgot to bump the minimum NSS version requirement, 
when up upgraded to NSS 3.21

We should fix that for Firefox 45 and 46.

(Firefox 47 already uses 3.22 and has been fixed already in bug .)
Assignee: nobody → kaie
Comment on attachment 8713570 [details] [diff] [review]
patch v1 for aurora 46 and beta 45 (and potentially release 44)

Linux distributions should be made aware that we require NSS 3.21 for building Firefox 44, 45 and 46.
Attachment #8713570 - Attachment description: patch v1 → patch v1 for aurora 46 and beta 45 (and potentially release 44)
Attachment #8713570 - Flags: approval-mozilla-release?
Attachment #8713570 - Flags: approval-mozilla-beta?
Attachment #8713570 - Flags: approval-mozilla-aurora?
Attachment #8713570 - Flags: review?(ted) → review+
Comment on attachment 8713570 [details] [diff] [review]
patch v1 for aurora 46 and beta 45 (and potentially release 44)

Taking it for aurora & beta.
Should be in 45 beta 2.
Attachment #8713570 - Flags: approval-mozilla-beta?
Attachment #8713570 - Flags: approval-mozilla-beta+
Attachment #8713570 - Flags: approval-mozilla-aurora?
Attachment #8713570 - Flags: approval-mozilla-aurora+
Hi Ryan, would you please be able to help me land that? If not I can try to do it later today. Thank you.
Flags: needinfo?(ryanvm)
302 to the sheriff in our TZ (Ryan is no longer doing that)
Flags: needinfo?(cbook)
https://hg.mozilla.org/releases/mozilla-aurora/rev/2bf5e0123345
https://hg.mozilla.org/releases/mozilla-beta/rev/4d96907bc1f0
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ryanvm)
Flags: needinfo?(cbook)
Resolution: --- → FIXED
Comment on attachment 8713570 [details] [diff] [review]
patch v1 for aurora 46 and beta 45 (and potentially release 44)

This seems like a safe ride-along in 44.0.1 release, Release44+
Attachment #8713570 - Flags: approval-mozilla-release? → approval-mozilla-release+
Adding a release note as this is part of 44.0.1. 
Wording: Require NSS 3.21 (with link to this bug)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.