If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

userContent.css settings don't get used

RESOLVED DUPLICATE of bug 1046166

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1046166
2 years ago
a year ago

People

(Reporter: Lokesh Mandvekar, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160126084715

Steps to reproduce:

My userContent.css looks like:

* {
    font: fixed !important;
    font-family: fixed !important;
    font-size: 10px !important;
}


Actual results:

Before the upgrade to 44.0, the 'Fixed' font used to get listed in my about:preferences#content. But it doesn't anymore.


Expected results:

Unless userContent.css isn't being used by firefox anymore, I should be able to see the 'Fixed' font in my fonts dropdown box.

Comment 1

2 years ago
Steps to reproduce:

I'm seeing issues with both userContent.css and userChrome.css after upgrade to 44.0.

Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0

For instance, the following in userContent.css, a site w/ <pre> tags, this has no effect.  Using the ff debugger and altering/adding values under pre {} has no effect.  This same method on chrome works fine.

pre {
  white-space: pre-wrap !important;
  word-wrap: break-word !important;
  font-size: 8.0pt !important;
  font-family: "Liberation Mono" !important;
}

So I believe this is more than just userContent.css being broken but the honoring of any css for (at least) pre tags (at least font-family and font-size).

Actual results:

Before upgrade to 44.0, Liberation Mono for pre tags was honored and rendered correctly.  Currently, I cannot modify font-family or font-size either through direct css editing or use of userContent.css

Expected results:

userContent.css should be honored for the values specified above (font-family, font-size)

Updated

2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

Comment 2

a year ago
Works for me with:

Name 	Firefox
Version 	46.0.1
Build ID 	20160502172042
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

However doesn't work for me with:

Name 	Firefox
Version 	48.0a2
Build ID 	20160520004020
Update Channel 	aurora
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

with the default setting of "Enable multi-process Firefox Developer Edition" checked.  Unchecking it makes my "userContent.css" rules applied again.

The later issue appears Bug 1046166.  I'm not really sure what this issue is about – the original description mixes mentioning "userContent.css", and font options missing on the "Preferences" pages, which are mostly unrelated to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1046166
You need to log in before you can comment on or make changes to this bug.