Unable to seek WebM audio by changing currentTime

RESOLVED DUPLICATE of bug 657791

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 657791
3 years ago
3 years ago

People

(Reporter: James Simpson, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160129030206

Steps to reproduce:

Started playing audio inside an Audio object, then tried to seek back to the beginning by setting currentTime to 0.


Actual results:

This works correctly in other browsers and with all other codecs, but does nothing with WebM. Test case:

https://jsfiddle.net/g05qg6ju/


Expected results:

The audio should have seeked to the beginning and continued playing from that point.

Updated

3 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
This file doesn't have webm cues and we do not support seeking into those webm.
It's being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657791
You need to log in before you can comment on or make changes to this bug.