Replace Bookmark broken due to bug 1233497

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: dgutov, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160128004012

Steps to reproduce:

I've got a report that my extension is broken: https://github.com/dgutov/bmreplace/issues/32#issuecomment-176126946

It imports PlacesUIUtils.jsm and calls three functions from it, most notably PlacesUIUtils.getDescriptionFromDocument.


Actual results:

The error console output looks like this:

unsafe CPOW usage main.js:39:8
unsafe CPOW usage main.js:40:8
unsafe CPOW usage main.js:40:14
Error: unsafe CPOW usage forbidden PlacesUIUtils.jsm:582:9
(Reporter)

Updated

3 years ago
Blocks: 1233497
Component: Untriaged → Extension Compatibility

Updated

3 years ago
Summary: Replace Bookmark broken due to 1233497 → Replace Bookmark broken due to bug 1233497
(Reporter)

Comment 1

3 years ago
I've worked around it in Replace Bookmark 1.6.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.