Intermittent bug-1232386.js | Assertion failure: zone->runtimeFromAnyThread()->gc.nursery.isEmpty()

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: philor, Assigned: jonco)

Tracking

({intermittent-failure})

Trunk
mozilla48
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 fixed, firefox48 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Comment 1

3 years ago
Created attachment 8730668 [details] [diff] [review]
bug1244412-zone-cell-iter-fix

The problem is that Zone::discardJitCode uses a ZoneCellIterUnderGC but can be called from AutoClearTypeInferenceStateOnOOM when not under a GC.

I think the easiest fix is to make ZoneCellIter work correctly whether called under a GC or not.
Assignee: nobody → jcoppeard
Attachment #8730668 - Flags: review?(terrence)
(Assignee)

Comment 2

3 years ago
Created attachment 8730669 [details] [diff] [review]
bug1244412-zone-cell-iter-refactor

I'm in two minds about this because I like the documentation aspect of calling the 'UnderGC' version of the iterator, but there doesn't seem to be that much point in keeping it if ZoneCellIter works for both cases.
Attachment #8730669 - Flags: review?(terrence)
Attachment #8730669 - Flags: review?(terrence) → review+
Attachment #8730668 - Flags: review?(terrence) → review+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1240736

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/51f649f844e1
https://hg.mozilla.org/mozilla-central/rev/a843f696dd44
https://hg.mozilla.org/mozilla-central/rev/3f07f0a72135
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
47 is marked as affected. Should this be uplifted?
Flags: needinfo?(jcoppeard)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8730668 [details] [diff] [review]
bug1244412-zone-cell-iter-fix

Approval Request Comment
[Feature/regressing bug #]: At the latest bug 1072564 but maybe earlier.
[User impact if declined]: Possible crash on OOM.
[Describe test coverage new/current, TreeHerder]: On m-c for over a month.
[Risks and why]: Low.
[String/UUID change made/needed]: None.
Flags: needinfo?(jcoppeard)
Attachment #8730668 - Flags: approval-mozilla-aurora?

Comment 9

3 years ago
Comment on attachment 8730668 [details] [diff] [review]
bug1244412-zone-cell-iter-fix

OOM Crash fix, has been on Nightly48 for over a month, Beta47+
Attachment #8730668 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+
(Assignee)

Updated

3 years ago
Depends on: 1264300
You need to log in before you can comment on or make changes to this bug.