Closed Bug 1244519 Opened 5 years ago Closed 5 years ago

fairphone2 doesn't flash to Phone after successful build. Unsupported device "FP2", can't flash

Categories

(Firefox OS Graveyard :: Hardware, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: i.hoerler, Assigned: gerard-majax)

References

()

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160126223146

Steps to reproduce:

I followed this:
01. https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Preparing_for_your_first_B2G_build and:
02. terminal code: sudo bash
03. terminal code: apt-get install phablet-tools android-tools-adb android-tools-fastboot
04. terminal code: mkdir ~/firefox_os
05. terminal code: cd firefox_os
06. terminal code: apt-get install git
07. terminal code: git clone git://github.com/mozilla-b2g/B2G.git && cd B2G
08. terminal code: ./config.sh
09. terminal code: ./config.sh fairphone2 - and off it goes for 2-3h
10. connected phone
11. de-checked all connection boxes and activated debug mode by pressing the last menu item 7 times. then a new menu called developer options apears. 
12. terminal code: adb devices - there must be more then just this: "List of devices attached" at least a number in front of Device.
13. terminal code: mkdir ~/fairphone_os
14. terminal code: cd fairphone_os
15. terminal code: adb pull /system ~/fairphone_os/system - that makes a backup of your momentary phone os
16. terminal code: adb pull /data ~/fairphone_os/data - maybe there is nothing and it will do nothng. Thats ok.
17. terminal code: adb pull /vendor ~/fairphone_os/vendor - may give a error. Check if you find a folder called vendor in the Fairphone_os/system folder.
18. https://developer.mozilla.org/en-US/Firefox_OS/Building
19. terminal code: apt-get install git
20. terminal code: git pull
21. terminal code: ./repo sync -d
22. terminal code: -/repo sync
23. terminal code: cd B2G
24. terminal code: ./build.sh -j8
25. https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Installing_on_a_mobile_device
26. terminal code: adb devices / -> List of devices attached / 234fa0 device
27. terminal code: ./flash.sh

28. terminal output: Unsupported device "FP2", can't flash


Actual results:

28. terminal output: Unsupported device "FP2", can't flash

then i also tried to set phone in fastboot mode and terminal code: fastboot devices gave out a devicename so i tried ./flash again but same result.


Expected results:

flashing the phone...
I confirm this bug. This is the output of flash.sh script under Ubuntu 14.04 LTS 64 bit.

+ . load-config.sh
++ [[ ! -n '' ]]
++++ dirname load-config.sh
+++ cd .
+++ pwd
++ B2G_DIR=/home/tore/Desktop/Firefox_OS/B2G
++ . /home/tore/Desktop/Firefox_OS/B2G/.config
+++ MAKE_FLAGS=-j6
+++ GECKO_OBJDIR=/home/tore/Desktop/Firefox_OS/B2G/objdir-gecko
+++ DEVICE_NAME=fairphone2
+++ PRODUCT_NAME=FP2
++ '[' 0 -ne 0 ']'
++ '[' -f /home/tore/Desktop/Firefox_OS/B2G/.userconfig ']'
++ '[' -z ']'
++ GECKO_PATH=/home/tore/Desktop/Firefox_OS/B2G/gecko
++ VARIANT=eng
++ PRODUCT_NAME=FP2
++ DEVICE=FP2
++ LUNCH=FP2-eng
++ DEVICE_DIR='device/*/FP2'
+ test -f 'device/*/FP2/flash.sh'
+ ADB=adb
+ FASTBOOT=fastboot
+ HEIMDALL=heimdall
+ VARIANT=eng
+ FULLFLASH=false
++ which adb
+ '[' '!' -f /usr/bin/adb ']'
++ which fastboot
+ '[' '!' -f '' ']'
++ uname -s
++ tr '[[:upper:]]' '[[:lower:]]'
+ FASTBOOT=out/host/linux-x86/bin/fastboot
+ '[' 0 -gt 0 ']'
+ case "$PROJECT" in
+ case "$DEVICE" in
++ type -t flash_FP2
+ [[ '' = function ]]
+ echo Unsupported device '"FP2",' 'can'\''t' flash
Unsupported device "FP2", can't flash
+ exit -1
Blocks: 1139642
It's just we forgot to add it to the flash script
Assignee: nobody → lissyx+mozillians
Attached file B2G PR
Juan, there was no pending PR for this so I did it. Can you verify on your device?
Attachment #8714094 - Flags: review?(jgomez)
Novski, thanks for the report. Since you are willing to produce images, I would suggest to also give extensive reading of the docs about updates :)

https://developer.mozilla.org/en-US/Firefox_OS/Building_and_installing_Firefox_OS/Firefox_OS_update_packages
Flags: needinfo?(i.hoerler)
seams like thats not all to me. 
I changed this line manualy: 
"panda"|"maguro"|"crespo"|"crespo4g"|"mako"|"hammerhead"|"flo"|"shamu")
to:
"panda"|"maguro"|"crespo"|"crespo4g"|"mako"|"hammerhead"|"flo"|"shamu"|"fairphone2")
as i seen in the link above to github.

But if i then save and ./flash.sh
it still shows : Unsupported device "FP2", can't flash

and if i try direct over: fastboot -p FP2 flashall
it shows this: error: could not load android-info.txt: No such file or directory
even i see the file in the directory: out/target/product/FP2/
it has only one line: board=FP2

Regards, Novski
Flags: needinfo?(i.hoerler)
PR should be good now, I mixed DEVICE and the way we handle them in the scripts.
Thanks for the report Novski!
Alex, yeah, that is what was missing.
Merged!
https://github.com/mozilla-b2g/B2G/commit/f7276c96cf8f8646069fc93b91428e08b38c074a
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> PR should be good now, I mixed DEVICE and the way we handle them in the
> scripts.

Yes, I found the same mistake on code. The device name have to be FP2 not fairphone2
PRODUCT_NAME=FP2
DEVICE=FP2
Now it works!!!
Comment on attachment 8714068 [details]
Screenshot from 2016-01-30 17:08:15.png

Ups! forgot to set the +! :)
Attachment #8714068 - Flags: review+
Attachment #8714094 - Flags: review?(jgomez) → review+
Hi 
That did work! now i was able to flash the device...
But uf corse there are more problems now. 
I will open a single bug for every problem i find.
But does any of the developers have a device to test or do you have to relay on my experiences?
Regards, Novski
Status: RESOLVED → VERIFIED
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(jgomez)
Flags: needinfo?(erotavlas_turbo)
I don't have one, but Juan has a device with him. What are the other issues you ran into? Mostly everything works as far as we could test on Juan's build yesterday.
Flags: needinfo?(lissyx+mozillians)
uh. so maybe mine is broken. I indeed had a blank phone because i tried to flash manualy and run in to a problem. It was totaly dead. not even the recovery booted. so it may be that i have to reflash the initial os befor i load firefox os...
I had no SIM or Cellular connection and a errormessage in the notification center, also i had no WIFI and the clock was reset every time i rebooted... :-)
I will try to compile and flash a FPOSOS and see how much works with that, then i get back.
Regards, Novski
Flags: needinfo?(erotavlas_turbo)
hi.
I now have problems to build. The build failed now several times and i can't say what i did else than yesterday... I was able to build until now... 
May somebody sync and try to build as well? just to be shure its not in the repo a problem...
Thanks, Novski
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(jgomez)
Flags: needinfo?(erotavlas_turbo)
(In reply to Novski from comment #13)
> hi.
> I now have problems to build. The build failed now several times and i can't
> say what i did else than yesterday... I was able to build until now... 
> May somebody sync and try to build as well? just to be shure its not in the
> repo a problem...
> Thanks, Novski
Try to start from scratch by typing "rm -rf out" from B2G folder in order to wipe out the previous build.
Flags: needinfo?(erotavlas_turbo)
(In reply to Novski from comment #13)
> hi.
> I now have problems to build. The build failed now several times and i can't
> say what i did else than yesterday... I was able to build until now... 
> May somebody sync and try to build as well? just to be shure its not in the
> repo a problem...
> Thanks, Novski

We cannot do anything without any complete log of the failure ran with |./build.sh -j1|
Flags: needinfo?(lissyx+mozillians)
Attached file Building bug
(In reply to Alexandre LISSY :gerard-majax from comment #15)
> (In reply to Novski from comment #13)
> > hi.
> > I now have problems to build. The build failed now several times and i can't
> > say what i did else than yesterday... I was able to build until now... 
> > May somebody sync and try to build as well? just to be shure its not in the
> > repo a problem...
> > Thanks, Novski
> 
> We cannot do anything without any complete log of the failure ran with
> |./build.sh -j1|

I confirm that there is bug error with latest code from github. The output code is generated by ./build.sh -j1.
(In reply to erotavlas from comment #16)
> Created attachment 8714744 [details]
> Building bug

That is not a complete build log, I don't even see the root cause. Please file a new bug.
You need to log in before you can comment on or make changes to this bug.