Bring back support of the QuickTime container after the gstreamer removal

VERIFIED FIXED in Firefox 45

Status

()

defect
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: evangelos, Assigned: jya)

Tracking

(Depends on 1 bug, {regression})

46 Branch
mozilla47
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox44 wontfix, firefox45+ verified, firefox46 verified, firefox47 verified)

Details

Attachments

(4 attachments)

Reporter

Description

3 years ago
I am not sure if the QuickTime file format is supposed to work after the GStreamer removal, but we got a report for this downstream in Arch Linux after disabling GStreamer (again :p) in our builds. [1]

If there are no plans to add support for QuickTime on Linux now that GStreamer is gone, feel free to close this as WONTFIX. (Perhaps the MP4 demuxer could be extended to support the QuickTime format?)

(This does not yet affect the official stable channel since GStreamer support was removed in Firefox 46.)

[1] https://bugs.archlinux.org/task/47953
[2] http://dl1.streamzilla.jet-stream.nl/preludecd/okt_15_bach_kunst_der_fuge_contrapunctus_I.mov
Assignee

Comment 1

3 years ago
Gstreamer is still supported in 44.
There is already support in Firefox for MP4 (aka QuickTime) without gstreamer
The issue in Arch Limux is that their ffmpeg is compiled without AAC support.

So it's not like there's no MP4/QuickTime support in Firefox.

Seeing that the only way gstreamer could in effect do either AAC or H264 was through the ffmpeg gstreamer plugin, compiling ffmpeg's libavcodec without h264 or AAC is just plain silly.

btw, arch Linux appears to believe that they have disabled H264. But they haven't. They enabled h264 via vaapi and vdpau. doing so automatically enable the software h264 decoder.

If arch Linux really want to disable those codecs the right way, they must disable h264 (including vaapi and vdpau). You can't in ffmpeg enable vaapi or vdpau without also enabling software h264

So until arch Linux fix their compilation of ffmpeg, it won't get MP4 with an AAC track playback.
I can't think of another distribution compiling ffmpeg that way.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Reporter

Comment 2

3 years ago
The MP4 container works fine in our builds; it's video/quicktime (QTFF) that doesn't play in Firefox but instead prompts for download.

We don't disable anything in our FFmpeg pacakge as far as I'm aware; I'm not sure where your assertions come from.

Again, H264/AAC works fine; it's the QuickTime file format that's not recognized by Firefox (without GStreamer). I've linked to a .mov file in my original comment; based on what I've seen so far, it should not play in Firefox 46 on Linux regardless of how fancy your system's FFmpeg is.

AGAIN, MP4 works fine; QuickTime doesn't. I do not mean MP4 when I specifically write QuickTime (.mov); please refrain from treating me like an idiot based on this confusion.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Assignee

Comment 3

3 years ago
My apologies. I got confused with another Linux distribution (Open Suse)
Assignee

Updated

3 years ago
See Also: → 1180101
Assignee

Updated

3 years ago
Assignee: nobody → jyavenard
Assignee

Comment 4

3 years ago
It's just like video/mp4
Attachment #8714147 - Flags: review?(cpearce)
Assignee

Comment 6

3 years ago
Similar to bug 1180101, but don't handle only the last box in the file.
Attachment #8714149 - Flags: review?(ajones)
Assignee

Updated

3 years ago
Keywords: regression
This fix needs a unit test.
Assignee

Updated

3 years ago
OS: Linux → All
Hardware: x86_64 → All
Summary: Support for QuickTime container on Linux (without GStreamer) → Support for QuickTime container
Assignee

Comment 8

3 years ago
Attachment #8714574 - Flags: review?(ajones)
Assignee

Comment 9

3 years ago
[Tracking Requested - why for this release]: This is a regression from 44. Also having proper support for QuickTime will allow to stop using the Quicktime plugin and use pure html5
Attachment #8714149 - Flags: review?(ajones) → review+
Attachment #8714574 - Flags: review?(ajones) → review+
Comment on attachment 8714147 [details] [diff] [review]
P1. Allow video/quicktime mimetype.

Review of attachment 8714147 [details] [diff] [review]:
-----------------------------------------------------------------

IE and Chrome play this on Windows. r+.
Attachment #8714147 - Flags: review?(cpearce) → review+
Attachment #8714148 - Flags: review?(cpearce) → review+
Assignee

Comment 13

3 years ago
Comment on attachment 8714147 [details] [diff] [review]
P1. Allow video/quicktime mimetype.

Approval Request Comment
[Feature/regressing bug #]: bug 1244523
[User impact if declined]: Regression for linux user now that GStreamer has been obsoleted: they can't play mov file. Other platforms have to use the Quicktime. There are currently over 70 bugs opened in relation to the Quicktime plugin crashing or not behaving as it should
[Describe test coverage new/current, TreeHerder]: Manual test, in central. 
[Risks and why]: Low. Piggy-backing on the existing MP4 decoder which is well tested (Quicktime/mov is almost identical to mp4)
[String/UUID change made/needed]: None
Attachment #8714147 - Flags: approval-mozilla-beta?
Attachment #8714147 - Flags: approval-mozilla-aurora?
Assignee

Comment 14

3 years ago
forgot to say that approval request is for all patches
Summary: Support for QuickTime container → Bring back support of the QuickTime container after the gstreamer removal
Comment on attachment 8714574 [details] [diff] [review]
[mp4] P4. Add gtest.

[Triage Comment]
Fix a recent regression, taking it.
Attachment #8714574 - Flags: approval-mozilla-beta+
Attachment #8714574 - Flags: approval-mozilla-aurora+
Attachment #8714149 - Flags: approval-mozilla-beta+
Attachment #8714149 - Flags: approval-mozilla-aurora+
Attachment #8714148 - Flags: approval-mozilla-beta+
Attachment #8714148 - Flags: approval-mozilla-aurora+
Attachment #8714147 - Flags: approval-mozilla-beta?
Attachment #8714147 - Flags: approval-mozilla-beta+
Attachment #8714147 - Flags: approval-mozilla-aurora?
Attachment #8714147 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
This patch made some .mov videos no longer work on Win 7.
http://download.wavetlan.com/SVV/Media/HTTP/BlackBerry.mov
http://download.wavetlan.com/SVV/Media/HTTP/MPEG4_AMR_3_(272%20KB).mov
"Video can't be played because the file is corrupt".
Browser console log: "Media resource http://download.wavetlan.com/SVV/Media/HTTP/MPEG4_AMR_3_(272%20KB).mov could not be decoded. MPEG4_AMR_3_(272%20KB).mov
TypeError: this.controlListeners is undefined"
Flags: needinfo?(jyavenard)
Assignee

Comment 19

3 years ago
there wasn't any native mov support prior that patch... 

http://download.wavetlan.com/SVV/Media/HTTP/MPEG4_AMR_3_(272%20KB).mov is an amr_nb audio track, and a mpeg4 part2 video which we don't support (we only support h264: mpeg4 part 10

http://download.wavetlan.com/SVV/Media/HTTP/BlackBerry.mov: this is a mp4v-es video track which we don't support (mp4v-es is the same as mpeg4 part 2)

So I don't see how they could "no longer work" seeing that they can't ever have worked.

Unless you have a plugin somewhere that was handling those files.
Flags: needinfo?(jyavenard)
(In reply to Jean-Yves Avenard [:jya] from comment #19)
> Unless you have a plugin somewhere that was handling those files.
Quicktime 7.7.6
Depends on: 1251184
I didn't have Arch Linux, but I managed to reproduce the problem on Ubuntu 14.04, nightly 2016-02-01.
Verified fixed 47.0a1 (2016-02-24), 46.0a2 (2016-02-24), 45b9.
Filed bug 1251184 for the issue in comment 18.
Assignee

Updated

3 years ago
Duplicate of this bug: 1193902

Updated

3 years ago
Depends on: 1259464
You need to log in before you can comment on or make changes to this bug.