[e10s] Ctrl+mouse wheel to change zoom level doesn't work if chrome input fields are focused (crashes tab)

RESOLVED FIXED in Firefox 47

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: arni2033, Assigned: khuey)

Tracking

({crash, regression, reproducible})

Trunk
mozilla47
crash, regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160129030206
STR:
1. Open http://example.org/
2. Press Ctrl+F to open and focus Findbar
3. Place mouse pointer over the page content, hold Ctrl and rotate mouse wheel up and down

AR:  Tab crashes
ER:  Tab should change zoom level

I think that crash is a recent regression. It doesn't happen on Dev.Edition 45
I was going to file this as simply Ctrl+Wheel not working, but now it also causes the crash...
Comment hidden (obsolete)
(Reporter)

Comment 2

2 years ago
Sorry, info in comment 0 is incorrect. I'm using:  Win7_64, Nightly 46, 32bit, ID 20160131030347
This is regression between 47.0a1 (2016-01-30) and 47.0a1 (2016-01-31).
Mozregression GUI can't handle this  =(
Keywords: regression, regressionwindow-wanted
Could you post a link to a crash report from about:crashes? Seeing the crash stack might allow us to identify the problem faster than a regression window.
Flags: needinfo?(arni2033)
(Reporter)

Comment 4

2 years ago
bp-a6532bae-c496-4bd2-aad3-70b262160201
Flags: needinfo?(arni2033)
Thanks! This looks likely to be a regression from bug 1241764.
Blocks: 1241764
Component: Panning and Zooming → DOM
Flags: needinfo?(khuey)
Keywords: regressionwindow-wanted
Yeah, looks like I effectively removed a null check.
Assignee: nobody → khuey
Flags: needinfo?(khuey)
(Reporter)

Comment 8

2 years ago
I was going to file separate bug on Ctrl+Wheel not changing the zoom level, unless
you will leave this bug open to track that issue after fixing the crash. So what is the plan here?
Note: zero relevant bugs found for "e10s zoom level"
(In reply to arni2033 from comment #8)
> I was going to file separate bug on Ctrl+Wheel not changing the zoom level,
> unless
> you will leave this bug open to track that issue after fixing the crash. So
> what is the plan here?

Please file a new bug for that - thanks!

Updated

2 years ago
Attachment #8714189 - Flags: review?(bugs) → review+

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/45c60b46bab9
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
(Reporter)

Updated

2 years ago
Blocks: 1245068
You need to log in before you can comment on or make changes to this bug.