Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

(Whiteboard: dom-triaged)

(Reporter)

Description

3 years ago
mochitest push started to go perma orange like https://treeherder.mozilla.org/logviewer.html#?job_id=3216622&repo=mozilla-central

maybe this is because this hits an external server.

So we hide this tests now. Kit, could you look at this maybe we need to adjust the tests or so ? If this problem is fixed we can unhide this test again
(Reporter)

Updated

3 years ago
Flags: needinfo?(kcambridge)
This was caused by a server issue that came up when the month rolled over: https://github.com/mozilla-services/autopush/issues/319 Once the server restarts, we should be able to unhide the tests. Keeping ni? until it's restarted.

We should also investigate removing the production server dependency from the mochitests. In this case, they correctly indicated there was a problem, though not with the DOM API implementation in Firefox.
See Also: → bug 1244816
The server has been restarted, and there are tickets for the two issues that caused the outage: https://github.com/mozilla-services/autopush/issues/319 and https://github.com/mozilla-services/autopush/issues/320. I think we can unhide the tests now.

They'll still fail intermittently until we switch to mocks, but shouldn't be perma-orange. Bug 1244816 tracks that work.
Flags: needinfo?(kcambridge)
(Setting dom-noted to make this not continue to show up in my triage queries)
Whiteboard: dom-noted
Component: DOM → DOM: Push Notifications
Whiteboard: dom-noted → dom-triaged
Unhidden, still marked as tier-2 but that's bug 1244816.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.