Closed Bug 1244729 Opened 7 years ago Closed 1 year ago

[PDF Viewer] Incorrect PDF display (large portions of the map appear as black)

Categories

(Firefox :: PDF Viewer, defect, P3)

43 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: t.kuchta, Unassigned)

References

Details

(Keywords: testcase, Whiteboard: [pdfjs-c-rendering])

Attachments

(1 file)

375.03 KB, application/pdf
Details
Attached file 757362.pdf
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_2) AppleWebKit/601.3.9 (KHTML, like Gecko) Version/9.0.2 Safari/601.3.9

Steps to reproduce:

A pdf file 757362.pdf is displayed incorrectly, compared to other PDF viewers.
The file contains a map. When opened with Firefox viewer, large portion of the map appears as black. In comparison, when the same file is opened e.g. in chromium, these black parts are grey-ish. 

The file comes from the Govdocs data set (http://digitalcorpora.org/corpora/govdocs)
It can be extracted from this archive: http://digitalcorpora.org/corp/files/govdocs1/zipfiles/757.zip

That was checked under Firefox 43.0.4 under Mac OS, but I expect similar results for the Linux version.

I would be grateful if you could confirm.



Actual results:

Incorrect display of the PDF file


Expected results:

PDF file displayed as in other viewers
Severity: normal → major
Hardware: Unspecified → x86_64
Component: Untriaged → PDF Viewer
Summary: Incorrect PDF display → [PDF Viewer] Incorrect PDF display (large portions of the map appear as black)
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Unspecified → All
Hardware: x86_64 → All
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering]
I would be grateful if you could confirm. Thank you!
(In reply to t.kuchta from comment #1)
> I would be grateful if you could confirm. Thank you!

It's confirmed, because the bug state has been changed from UNCONFIRMED to NEW.
Thanks!

Works for me with Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0

Mozregression shows that this bug was fixed between 2017-09-13 and 2017-09-14, but bisect has not enough data.

Likely fixed by bug 1399689.

Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1399689
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.