VS2015 build error: ipc/glue/GeckoChildProcessHost.cpp(640): error C2672: 'nsAString_internal::InsertLiteral': no matching overloaded function found

RESOLVED DUPLICATE of bug 1244774

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 1244774
2 years ago
2 years ago

People

(Reporter: xidorn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

14:36.17 ipc/glue/GeckoChildProcessHost.cpp(640): error C2672: 'nsAString_internal::InsertLiteral': no matching overloaded function found
14:36.17 ipc/glue/GeckoChildProcessHost.cpp(640): error C2784: 'void nsAString_internal::InsertLiteral(const nsAString_internal::char_type (&)[N],nsAString_internal::index_type)': could not deduce template argument for 'const nsAString_internal::char_type (&)[N]' from 'const wchar_t [7]'
14:36.20 obj-firefox-opt\dist\include\nsTSubstring.h(709): note: see declaration of 'nsAString_internal::InsertLiteral'
14:36.21 ipc/glue/GeckoChildProcessHost.cpp(643): error C2672: 'nsAString_internal::AppendLiteral': no matching overloaded function found
14:36.22 ipc/glue/GeckoChildProcessHost.cpp(643): error C2780: 'bool nsAString_internal::AppendLiteral(const char (&)[N],const nsAString_internal::fallible_t &)': expects 2 arguments - 1 provided
14:36.24 obj-firefox-opt\dist\include\nsTSubstring.h(646): note: see declaration of 'nsAString_internal::AppendLiteral'
14:36.26 ipc/glue/GeckoChildProcessHost.cpp(643): error C2784: 'void nsAString_internal::AppendLiteral(const char (&)[N])': could not deduce template argument for 'const char (&)[N]' from 'const wchar_t [3]'
14:36.26 obj-firefox-opt\dist\include\nsTSubstring.h(640): note: see declaration of 'nsAString_internal::AppendLiteral'
14:36.29 ipc/glue/GeckoChildProcessHost.cpp(643): error C2784: 'void nsAString_internal::AppendLiteral(const nsAString_internal::char_type (&)[N])': could not deduce template argument for 'const nsAString_internal::char_type (&)[N]' from 'const wchar_t [3]'
14:36.29 obj-firefox-opt\dist\include\nsTSubstring.h(634): note: see declaration of 'nsAString_internal::AppendLiteral'
14:36.32 ipc/glue/GeckoChildProcessHost.cpp(645): error C2664: 'void std::vector<std::wstring,std::allocator<_Ty>>::push_back(const std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t>> &)': cannot convert argument 1 from 'char16ptr_t' to 'std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t>> &&'
14:36.32         with
14:36.35         [
14:36.35             _Ty=std::wstring
14:36.37         ]
14:36.37 ipc/glue/GeckoChildProcessHost.cpp(645): note: Reason: cannot convert from 'char16ptr_t' to 'std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t>>'
14:36.39 ipc/glue/GeckoChildProcessHost.cpp(645): note: No user-defined-conversion operator available that can perform this conversion, or the operator cannot be called
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244774
You need to log in before you can comment on or make changes to this bug.