Closed Bug 1245051 Opened 7 years ago Closed 7 years ago

Support GTK3 overlay scrollbars

Categories

(Core :: Widget: Gtk, defect)

45 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1147847

People

(Reporter: tagrain, Unassigned)

References

Details

Attachments

(2 files)

Attached image actual.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160128104122

Steps to reproduce:

load a page with more content than fits in the viewport


Actual results:

a really ugly scrollbar appears


Expected results:

a nice, GTK3 overlay scrollbar.
Version: 46 Branch → 45 Branch
Attached image gnome-scrollbars.png
this is what the scrollbar should do
Blocks: gtk3
Component: General → Widget: Gtk
OS: Unspecified → Linux
This issue could be retitled in order to be less misleading. The reporter wants Firefox to support _overlay scrollbars_ (Ubuntu enables upstream Gtk+ overlay scrollbars by default). If they are ugly or not in their non-overlay form, that is not a Firefox problem, as the styling is managed entirely by the Ambiance theme (report issues against it in Launchpad.net/ubuntu-themes, not here).
Summary: GKT3 overlay scrollbars are ugly → Support GTK3 overlay scrollbars
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147847
You need to log in before you can comment on or make changes to this bug.