Closed Bug 1245053 Opened 4 years ago Closed 4 years ago

Upgrade Mozilla 47 to use NSS 3.23

Categories

(Firefox Build System :: General, defect)

47 Branch
defect
Not set

Tracking

(firefox47 fixed)

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: kaie, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Upgrade Mozilla 47 to use NSS 3.23
Depends on: 1243455
Keywords: leave-open
combined commit that landed NSPR_4_12_BETA2 and NSS_3_23_BETA2:
https://hg.mozilla.org/integration/mozilla-inbound/rev/44ab9df0cd78
Thanks for the upgrade, Kai!
Blocks: winclang
No longer depends on: 1243455
Depends on: 1234698
Attached patch make.patch (obsolete) — Splinter Review
This is a change to the Firefox makefile, which is required when using the zlib makefile changes that are included with NSS 3.23

The patch was provided by EKR, see bug 1243872 comment 15.

r=kaie
Attachment #8716653 - Flags: review+
Attached patch make2.patchSplinter Review
updated the makefile patch, because the symbol was renamed
Attachment #8716653 - Attachment is obsolete: true
Attachment #8716944 - Flags: review+
Landed NSS_3_23_BETA4
Attachment #8716944 - Flags: checkin+
Blocks: 1247250
We'd like to finalize NSS 3.23 soon.
I've tagged a NSS_3_23_BETA5 which we should land into mozilla-inbound.

mt, can you please give me r=mt for landing that?

But let's see first if it works:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7d1774c9f288
Flags: needinfo?(martin.thomson)
r+ from me
Flags: needinfo?(martin.thomson)
Blocks: 1247860
There have been several late changes to the NSS trunk.
We need to test these new changes in mozilla-central.
I'll tag and land a new beta6.
make that beta7 ...
Backed out the suspected patch, tagged a beta8, try build started
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b8fe5fca4abc
Try build of beta8 looks ok to me, ttaubert agreed.
I tagged a release candidate NSS_3_23_RC0.
Only change on top of beta 8 are the new root CA changes from bug 1247990.

The plan is to wait a couple of more days for any regression reports, then tag the final RTM and land into then-aurora-47 next week.
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/5e135136e21c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.