Closed Bug 1245202 Opened 4 years ago Closed 4 years ago

Higher number of OOMs on 45

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 45
Tracking Status
firefox45 --- fixed

People

(Reporter: kbrosnan, Assigned: kbrosnan)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1235855 +++

crash-stats is indicating a higher crash right on 45, and most of those seem to be coming from OOM-related issues. I am guessing that it could be more fallout from bug 1182665, where we increased the tile dimensions for some devices.
Assignee: nobody → kbrosnan
Kevin, I am planning to build beta3 today. I don't see a fix, are you ready for this bug?
Flags: needinfo?(kbrosnan)
Yeah I'll have the patch moved over.
Flags: needinfo?(kbrosnan)
Approval Request Comment
[Feature/regressing bug #]: Not sure
[User impact if declined]: more crashes as a whole for users
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: disables new feature
[String/UUID change made/needed]:
Attachment #8715887 - Flags: review?(snorp)
Attachment #8715887 - Flags: approval-mozilla-beta?
Attachment #8715887 - Flags: review?(snorp) → review+
Comment on attachment 8715887 [details] [diff] [review]
Disable dynamic tile size for beta

Taking it for beta 3.
Attachment #8715887 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/f478a79b7625
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
Verified that the fix is in Firefox 45 Beta 3, "layers.enable-tiles" pref is set to "false".
Can't verify as fixed, since I wasn't able to reproduce this on older builds. We should keep an eye for this in crash-stats.mozilla.com.
Do you mean layers.tiles.adjust? We definitely don;t want layers.enable-tiles to be false.
(In reply to Jamie Nicol [:jnicol] from comment #7)
> Do you mean layers.tiles.adjust? We definitely don;t want
> layers.enable-tiles to be false.

Real sorry about that, I meant "layers.tiles.adjust" is set to false
You need to log in before you can comment on or make changes to this bug.