crash in `anonymous namespace''::wasapi_stream_start

RESOLVED DUPLICATE of bug 1246108

Status

()

--
critical
RESOLVED DUPLICATE of bug 1246108
3 years ago
2 years ago

People

(Reporter: rctgamer3, Assigned: kinetik)

Tracking

({crash, topcrash})

unspecified
Unspecified
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox46+ fixed, firefox47+ fixed, firefox48+ fixed)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-0f5b4b28-6a6d-4161-8348-9357e2160203.
=============================================================
Was viewing a random YouTube video and the audio just shat itself. Audio stopped playing, while video continued. This continued for two seconds until i heard strange audio clicks/pops and Firefox (DevEdition 46.0a2 (2016-02-02)) crashed.
[Tracking Requested - why for this release]:

This has been a significant crash on nightly since the 20160113030208 build.  See:
https://crash-stats.mozilla.com/signature/?product=Firefox&release_channel=nightly&platform=Windows&date=%3E%3D2015-07-01&signature=%60anonymous+namespace%27%27%3A%3Awasapi_stream_start#aggregations

There were some crashes before then, but the numbers have been higher on 46 and later than on earlier releases.  (This includes 46.0b1.)
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
tracking-firefox46: --- → ?
Flags: needinfo?(ajones)
Keywords: topcrash
bug 948267 seems the most likely to me in that range, although I might be missing something else relevant
Bug 1246108 is to fix this crash which can be reproduced by enabling the crashtest video-replay-after-audio-end.html on Windows.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d23a6dcd329a&selectedJob=18003987
https://hg.mozilla.org/try/rev/e965ba0560d4
Flags: needinfo?(ajones) → needinfo?(kinetik)
#6 crash in 46 beta, tracking. Sounds like we are close to a fix in bug 1246108.
tracking-firefox46: ? → +
tracking-firefox47: --- → +
(Assignee)

Updated

2 years ago
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Flags: needinfo?(kinetik)
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246108
Tracked in the duplicate bug.
status-firefox46: affected → fixed
status-firefox47: affected → fixed
status-firefox48: affected → fixed
tracking-firefox48: --- → +
You need to log in before you can comment on or make changes to this bug.