Closed Bug 1245413 Opened 5 years ago Closed 4 years ago

Make it an error to have a "use strict" directive in a function with a non-simple parameter list

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1272784

People

(Reporter: 446240525, Unassigned)

References

Details

(Whiteboard: [DocArea=JS])

js> function f(a=1){"use strict"} // should be an early error

V8 proposed[1] and implemented[2] this change last year, and Chakra implemented it yesterday[3].

[1] https://github.com/rwaldron/tc39-notes/blob/master/es7/2015-07/july-29.md#611-the-scope-of-use-strict-with-respect-to-destructuring-in-parameter-lists
[2] https://codereview.chromium.org/1300103005
[3] https://github.com/Microsoft/ChakraCore/issues/246
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1272784
You need to log in before you can comment on or make changes to this bug.