turn off android talos tests which run on the panda boards

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
11 months ago

People

(Reporter: jmaher, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
now that we have autophone running tp4m and tsvgx on nexus 6p's we should be turning off the panda boards.

The pandas have coverage on:
mozilla-beta
mozilla-aurora
mozilla-inbound
fx-team
mozilla-central
try

We don't have this coverage, but I assert that we just need coverage on:
mozilla-inbound
fx-team
try

currently we will be lacking try coverage- probably ok to start turning off the panda boards and waiting a few weeks until we get more capacity (the other 6p's need to get to MTV and racked).
(Reporter)

Comment 1

3 years ago
:bc, any concerns with moving forward on this bug?
Flags: needinfo?(bob)
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
(Assignee)

Comment 2

3 years ago
to clarify, you are asking that all talos tests that run on pandas be disabled despite the lack of complete coverage on autophone?
Flags: needinfo?(jmaher)
(Reporter)

Comment 3

3 years ago
kmoir, yes- I am asking to turn off ALL talos android jobs, this is all branches.  I wanted to call out that we don't have full branch coverage yet- the appropriate parties are cc'd on here and we briefly discussed this topic in the mobile testing meeting today.
Flags: needinfo?(jmaher)

Comment 4

3 years ago
We need to actually turn the talos tests on for the 6Ps first.
Flags: needinfo?(bob)
(Assignee)

Comment 5

3 years ago
patch to remove remaining panda talos jobs
(Assignee)

Comment 6

3 years ago
builder diff
(Assignee)

Updated

3 years ago
Attachment #8715962 - Flags: review?(alin.selagea)
Comment on attachment 8715962 [details] [diff] [review]
bug1245585.patch

Looks good.
Attachment #8715962 - Flags: review?(alin.selagea) → review+
(Assignee)

Comment 9

3 years ago
more patches to remove panda platform after initial patch is landed and panda jobs stop
Attachment #8716433 - Flags: review?(alin.selagea)
(Assignee)

Comment 10

3 years ago
Posted patch bug1245585puppet.patch (obsolete) — Splinter Review
patches to remove password template from puppet and decom masters
Attachment #8716436 - Flags: review?(alin.selagea)
Attachment #8716433 - Flags: review?(alin.selagea) → review+
Attachment #8716436 - Flags: review?(alin.selagea) → review+
(Assignee)

Comment 11

3 years ago
unbitrotten patch
(Assignee)

Comment 12

3 years ago
new builder diff same as old builder diff
(Reporter)

Comment 13

3 years ago
I assume there are no blockers other than patches and r+, if there are please raise them!
(Assignee)

Updated

3 years ago
Attachment #8728564 - Flags: checked-in+
(Assignee)

Comment 14

3 years ago
patch updated to reflect moving funsize scheduler to a master that isn't being deccomissioned
Attachment #8716436 - Attachment is obsolete: true
Attachment #8728630 - Flags: review?(alin.selagea)
(Assignee)

Comment 15

3 years ago
remove panda masters from tools repo
Attachment #8728635 - Flags: review?(alin.selagea)
Attachment #8728630 - Flags: review?(alin.selagea) → review+
Attachment #8728635 - Flags: review?(alin.selagea) → review+
(Reporter)

Comment 18

3 years ago
does this mean we can turn off the foopies and officially get rid of the panda boards?
(Assignee)

Comment 19

3 years ago
yessssss.  I'm going to disable the panda masters with the next reconfig
(Assignee)

Updated

3 years ago
Attachment #8728635 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1186617
(Assignee)

Comment 21

3 years ago
Comment on attachment 8728630 [details] [diff] [review]
bug1245585puppet-2.patch

and merged to producton
Attachment #8728630 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

3 years ago
Comment on attachment 8716433 [details] [diff] [review]
bug1245585-2.patch

forgot this one
Attachment #8716433 - Flags: checked-in+
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.