Acrobat PDF plug-in fails to completely draw its' chrome on load in Mozilla

VERIFIED FIXED in mozilla1.0

Status

()

Core
Plug-ins
P2
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Greg K., Assigned: Peter Lubczynski)

Tracking

Trunk
mozilla1.0
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020405

The Acrobat PDF plug-in fails to completely draw its' own chrome when invoked in
Mozilla, leaving parts of the previous document visible.

Reproducible: Always
Steps to Reproduce:
1. Access a normal HTML document such as [http://www.mozilla.org]
2. Access a PDF document such as the example URL.

Actual Results:  The Acrobat Plug-in fails to completely draw its' chrome,
leaving parts of the previous document visible.

Expected Results:  The plug-in should have completely drawn its' chrome,
overwriting the old document.

If the Mozilla window is hidden, then redisplayed, the plug-in chrome is fully
displayed.

The plug-in works as expected in Mac IE 5.1.3 (4012).
(Reporter)

Comment 1

17 years ago
Created attachment 68705 [details]
Screen shot of incompletely rendered plug-in chrome

Observe the incompletely rendered plug-in chrome in this screen shot.

1. Missing "Bookmarks" and "Thumbnails" tabs along the left side
2. Missing plug-in sidebar widget at bottom-left
3. Missing zoom percentage drop-down menu widget in toolbar
4. Incompletely drawn toolbar background at right, leaving previous black
(Reporter)

Comment 2

17 years ago
Acrobat plug-in version used is that included with Acrobat Reader 5.0.5, a
Carbon application.

Comment 3

17 years ago
WFM [Mozilla 2002020803, Windows 2000, Acrobat reader 5.0.5]

it is a slow document to use tho, maybe its using up too much of your video RAM
(how much of that do you have?)

Comment 4

17 years ago
I had seen this...does not happen when I have just ns6.x open. But with other 
apps running...this is seen. Part of the acrobat UI does not paint unless forced 
to redraw...true
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
-->peterl

Possibly related to bug 120168 
Assignee: av → peterl
Depends on: 120168
Keywords: mozilla1.0
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 6

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Comment 7

17 years ago
nominating nsbeta1, thisis pretty bad
Keywords: nsbeta1

Comment 8

17 years ago
Created attachment 75402 [details] [diff] [review]
patch to invalidate

Yeah, this is pretty bad. Here's a patch that seems to make it better.

Updated

17 years ago
Status: NEW → ASSIGNED
No longer depends on: 120168
Keywords: patch

Comment 9

17 years ago
Is this patch going to cause an additional 'flash' every time any full page
plugin is loaded?

Comment 10

17 years ago
have not yet tested on Windows or Linux. it's possible it needs some #ifdefs

Comment 11

17 years ago
Created attachment 75647 [details] [diff] [review]
updated patch to exclude other platforms except for Mac

Mac is the only platform showing this problem because it does not have child
windows so this fix is Mac-only. This fix is not appropriate for other
platforms and may even cause a flicker.
Attachment #75402 - Attachment is obsolete: true

Comment 12

17 years ago
Comment on attachment 75647 [details] [diff] [review]
updated patch to exclude other platforms except for Mac

r=av

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Target Milestone: mozilla1.2alpha → mozilla1.0

Comment 13

17 years ago
adding adt2 to status whiteboard as per discussion with beppe.  this only
happens to mac users, although a patch is available already.
Whiteboard: [ADT2]

Comment 14

17 years ago
Comment on attachment 75647 [details] [diff] [review]
updated patch to exclude other platforms except for Mac

sr=beard
Attachment #75647 - Flags: superreview+

Comment 15

17 years ago
Comment on attachment 75647 [details] [diff] [review]
updated patch to exclude other platforms except for Mac

from comments
Attachment #75647 - Flags: review+

Comment 16

17 years ago
Comment on attachment 75647 [details] [diff] [review]
updated patch to exclude other platforms except for Mac

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #75647 - Flags: approval+

Comment 17

17 years ago
patch on trunk, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
I confirm this is resolved using Mac/2002032808.

Comment 19

17 years ago
Thanks a lot, Greg! VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.