Closed Bug 1245698 Opened 6 years ago Closed 6 years ago

"sendAsyncMessge" in ContentCrashHandlers.jsm is probably a typo

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1242907
Tracking Status
e10s ? ---
firefox44 --- unaffected
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

Attachments

(2 files)

Bug 1220929 may have had a typo in its fix.

It added a call to "message.target.sendAsyncMessge".  (Note the missing "a" in "Messge" there.)

MXR says we do have other usages of the quirky name "Messge", but this is the only usage of "sendAsyncMessge":
 http://mxr.mozilla.org/mozilla-central/search?string=sendAsyncMessge
and we do have lots of other usages that include the "a". So I think this was a typo.

(Also, I'm hitting an issue where sometimes the crash reporter doesn't show up in my tab crashed dialog, and right around when that happens I get this in my error console:
> message.target.sendAsyncMessge is not a function ContentCrashHandlers.jsm:231:0
...which I think might mean that this typo is causing that issue, though I'm not sure.)
Haven't tested this (not sure how to reliably), but I'm hoping you can confirm that this is what you intended.
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Attachment #8715563 - Flags: review?(mconley)
Attachment #8715563 - Attachment description: fix v1 → fix v1: s/Messge/Message/ (add missing "a")
(In reply to Daniel Holbert [:dholbert] from comment #0)
> (Also, I'm hitting an issue where sometimes the crash reporter doesn't show
> up in my tab crashed dialog

(Meant to say "tab-crashed page", not dialog. And, I've just attached a screenshot of that, for reference. If this bug's patch doesn't fix that issue, I'll spin that off into a new bug.)
Already being taken care of in bug 1242907! :D
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242907
Attachment #8715563 - Flags: review?(mconley)
You need to log in before you can comment on or make changes to this bug.