FATAL ERROR: AsyncShutdown in Media shutdown: blocking on media thread

RESOLVED DUPLICATE of bug 1228788

Status

()

Core
WebRTC: Audio/Video
--
critical
RESOLVED DUPLICATE of bug 1228788
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

({crash})

44 Branch
x86_64
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 unaffected, firefox46 unaffected, firefox47 unaffected)

Details

(Reporter)

Description

2 years ago
Affected versions: 44.0RC build 1, 44.0RC build 3
Affected platforms: Mac OS X 10.9.5, Mac OS X 10.11.1

Steps to reproduce:
1. Launch Firefox with a clean profile.
2. Click on Hello button.
3. Click on Get Started.
4. Select 'Start a conversation'.
5. Click the menu button, click Help Menu and select About Firefox.
6. When prompted, click on Restart Firefox to Update button.

Expected result: Updates are applied and Firefox successfully restarts.

Actual result: Crash - bp-e72ed27b-ec5c-4c6f-8b59-e1be62160204

Additional notes:
1. Crash occurs when applying updates from: 
* 44.0RC build 1 to the latest 44.0RC build 3
** bp-62f9324a-def4-437c-b4ad-6b9332160204
* 44.0RC build 3 to 45 beta 2 (on 'beta-cdntest' update channel)
** bp-e72ed27b-ec5c-4c6f-8b59-e1be62160204

2. Reproducible when applying updates from 45.0a1 from 2015-12-01 to the latest 47.0a1 (E.g.: bp-5a08939d-3e8d-4523-a69d-1ca5f2160204), but it *does not reproduce* when applying updates from 45.0a1 from 2015-12-05 - maybe bug 1228788 is involved somehow with this report.

3. Terminal output when the crash occurs:
JavaScript error: resource://gre/modules/PerformanceStats.jsm, line 492: Error: forget() called twice
WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"Media shutdown: blocking on media thread","state":"(none)","filename":"/builds/slave/m-cen-m64-ntly-000000000000000/build/src/dom/media/MediaManager.cpp","lineNumber":1600,"stack":"Media shutdown"}] Barrier: profile-before-change
JavaScript error: chrome://loop/content/modules/MozLoopPushHandler.jsm, line 73: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebSocketChannel.asyncOpen]
FATAL ERROR: AsyncShutdown timeout in profile-before-change Conditions: [{"name":"Media shutdown: blocking on media thread","state":"(none)","filename":"/builds/slave/m-cen-m64-ntly-000000000000000/build/src/dom/media/MediaManager.cpp","lineNumber":1600,"stack":"Media shutdown"}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.
[Parent 3254] ###!!! ABORT: file /builds/slave/m-cen-m64-ntly-000000000000000/build/src/dom/media/MediaManager.cpp, line 1600
Flags: needinfo?(padenot)
Flags: needinfo?(nical.bugzilla)
(Reporter)

Updated

2 years ago
Severity: normal → critical
Need to investigate if Bug 1228788 regressed or if this is something new (unrelated to Mac + camera).
From the clarification in bug 1228788 (and the restated description here which corrects the STR) this is just bug 1228788.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(padenot)
Flags: needinfo?(nical.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1228788
You need to log in before you can comment on or make changes to this bug.