If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

(tracker) Support TaskCluster for advance MozCI requests

RESOLVED FIXED

Status

Taskcluster
Platform and Services
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: armenzg, Assigned: armenzg)

Tracking

Details

(Assignee)

Description

2 years ago
I would like to tackle this next quarter.

Related issues:
https://github.com/mozilla/mozilla_ci_tools/issues/132
https://github.com/mozilla/mozilla_ci_tools/issues/413 (probably)
https://github.com/mozilla/mozilla_ci_tools/issues/424
https://github.com/mozilla/mozilla_ci_tools/issues/426

TODO: Review exact needs for MVP. Some of the issues might be tackled after MVP.
(Assignee)

Updated

2 years ago
Depends on: 1232005
(Assignee)

Comment 1

2 years ago
TODO: review these two branches to see what would be useful for this work:
* https://github.com/mozilla/pulse_actions/compare/master...armenzg:rebuild_tc_jobs
* https://github.com/mozilla/mozilla_ci_tools/compare/master...armenzg:rebuild_taskcluster
Moving to TaskCluster component...
Component: TaskCluster → Integration
Product: Testing → Taskcluster
(Assignee)

Updated

2 years ago
No longer depends on: 1232005
(Assignee)

Comment 3

2 years ago
There are many functions in mozci.py that do not have equivalent TaskCluster function [1] (e.g determine_trigger_objective)

[1] https://github.com/mozilla/mozilla_ci_tools/blob/master/mozci/mozci.py
(Assignee)

Comment 4

a year ago
I've been experimenting with the idea that the developer could use its own credentials to schedule tasks, however, there are some difficulties with treeherder scopes and routes. See thread [1]

I spoke with dustin and we agreed that I go back to the idea that pulse_actions would have its own set of credentials to do the scheduling.

The script that shows the problem is in here [3]. You won't be able to schedule a Linux64 TC with your temporary credentials.

[1] https://groups.google.com/d/msg/mozilla.tools.taskcluster/nkzBlX7BgrU/5aZj3uvBAQAJ
[2] 
2:44 PM <armenzg> dustin: I am thinking of going back to the idea that pulse_actions can schedule a task on Treeherder that would schedule the graph it needs to
2:44 PM <armenzg> rather than experimenting with the idea that a user would do the scheduling
2:44 PM <dustin> ok
2:44 PM <armenzg> there are too many rough edges
2:45 PM <armenzg> you agreed too easily :)
2:45 PM <armenzg> haha
[3] https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Farmenzg%2FTC_developer_scheduling_experiments%2Fblob%2Fschedule_linux_task%2Fschedule_linux64_task.py&sa=D&sntz=1&usg=AFQjCNFuRGNIe6oORq60fEWm8-WS8ha7XQ
Component: Integration → Platform and Services
(Assignee)

Comment 5

a year ago
Some of the original issues are fixed.
In any case, we've fixed enough.
We can file more bugs for new features.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.