webgl broken firefox 44, ubuntu

UNCONFIRMED
Unassigned

Status

()

Core
Canvas: WebGL
P3
normal
UNCONFIRMED
2 years ago
3 months ago

People

(Reporter: brendan c, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
Was working as of Jan 24, the last time I used a webgl enabled website (onshape.com). Today (since upgrade to 44.0) the site complains that my browser doesn't support webgl. Tried some chrome experiments, they also say my browser doesn't support webgl. These sites continue to work fine with Chromium.

Tried setting webgl.force-enable=true (per advice on internets), no luck.

Here is my environment info from about:healthreport

"environment": {
    "build": {
      "applicationId": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
      "applicationName": "Firefox",
      "architecture": "x86-64",
      "buildId": "20160125133541",
      "version": "44.0",
      "vendor": "Mozilla",
      "platformVersion": "44.0",
      "xpcomAbi": "x86_64-gcc3",
      "hotfixVersion": "20160106.01"
    },
    "partner": {
      "distributionId": "canonical",
      "distributionVersion": "1.0",
      "partnerId": null,
      "distributor": null,
      "distributorChannel": null,
      "partnerNames": []
    },
    "system": {
      "memoryMB": 7668,
      "virtualMaxMB": null,
      "cpu": {
        "count": 4,
        "cores": 2,
        "vendor": "GenuineIntel",
        "family": 6,
        "model": 61,
        "stepping": 4,
        "l2cacheKB": 256,
        "l3cacheKB": 4096,
        "speedMHz": 3200,
        "extensions": [
          "hasMMX",
          "hasSSE",
          "hasSSE2",
          "hasSSE3",
          "hasSSSE3",
          "hasSSE4_1",
          "hasSSE4_2"
        ]
      },
      "os": {
        "name": "Linux",
        "version": "4.2.0-25-generic",
        "locale": "en-US"
      },
      "hdd": {
        "profile": {
          "model": null,
          "revision": null
        },
        "binary": {
          "model": null,
          "revision": null
        },
        "system": {
          "model": null,
          "revision": null
        }
      },
      "gfx": {
        "D2DEnabled": null,
        "DWriteEnabled": null,
        "adapters": [
          {
            "description": "Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) ",
            "vendorID": "Intel Open Source Technology Center",
            "deviceID": "Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) ",
            "subsysID": null,
            "RAM": null,
            "driver": null,
            "driverVersion": "3.0 Mesa 11.0.2",
            "driverDate": null,
            "GPUActive": true
          }
        ],
        "monitors": [],
        "features": {
          "compositor": "basic"
        }
      }
    },
Please check if the same happens with http://archive.mozilla.org/pub/firefox/releases/44.0/linux-x86_64/en-US/firefox-44.0.tar.bz2 (make sure you test with a new profile to eliminate modifications as a potential cause). If it does not reproduce with this build then this is a bug in Ubuntu's version and needs to be escalated to Canonical.
If it does happen with the official mozilla build. Then finding a regression window using mozregression (http://mozilla.github.io/mozregression/) would be very valuable.
Flags: needinfo?(bcolloran)
(Reporter)

Comment 3

2 years ago
Since I filed this bug, my build has moved on to:
      "buildId": "20160209234513",
      "version": "44.0.2"
and whatever the problem was, it seems to have stopped...

Thanks for the help!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bcolloran)
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
(Reporter)

Comment 4

2 years ago
Curiously, this same error has reappeared since upgrading to 45 from 44.0.2

"application": {
    "architecture": "x86-64",
    "buildId": "20160304114936",
    "name": "Firefox",
    "version": "45.0",
    "vendor": "Mozilla",
    "platformVersion": "45.0",
    "xpcomAbi": "x86_64-gcc3",
    "channel": "release"
  },
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to brendan c from comment #4)
> Curiously, this same error has reappeared since upgrading to 45 from 44.0.2

I reiterate comment 2. If this happens in an official Mozilla build (not the version Ubuntu packages) then please use Mozregression to find the regression window. Thank you.
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Whiteboard: [gfx-noted]
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.