Flash is slower in 0.9.8+ than in 0.9.7

VERIFIED WONTFIX

Status

()

Core
Plug-ins
P4
normal
VERIFIED WONTFIX
17 years ago
16 years ago

People

(Reporter: Sitsofe Wheeler, Assigned: av (gone))

Tracking

({regression})

Trunk
Future
x86
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

432.86 KB, application/x-shockwave-flash
Details
(Reporter)

Description

17 years ago
BuildID: 20020208

When visiting sites which use flash, I have noticed that there is often loss of
speed in Mozilla 0.9.8+ in comparison to Mozilla 0.9.7 (or Netscape 4 for that
matter).

Reproducible: Always
Steps to Reproduce:
1. Visit a site which uses flash (e.g. http://games.sohu.com/fightgame/fight3.htm)
2. Compare performance to earlier Moz's/Netscape 4

Actual Results:  Flash displayed slowly

Expected Results:  Flash to be displayed at least as quickly as it was in Netscape 4

It is not so severe in 20020208 but it's still slower than Netscape 4 (and seems
to pause too)...
cc: blizzard who did some work here with bug 117398 and pav who had the famous
timer code.  :)

I had bz run an informal tests on this flash file and he noticed a 5 second
regression in time.

141s with 2001-12-13-08 ( 2 days before pavlov's timer code landed )
146s with current trunk build.

which is ~3.5% regression and cause for some investigation.  I don't see any
pausing at all which the reporter noted.

Also updating URL to point to the flash file directly.
Keywords: regression
Summary: Flash in 0.9.8+ is slower than in 0.9.7 → Flash is slower in 0.9.8+ than in 0.9.7
It's probably going to be a little slower, but that's the tradeoff for not
starving the UI event queue and timer queue and still giving reasonable
performance for flash animations.
(Reporter)

Comment 3

16 years ago
It also also quite a bit slower than Opera 6.2 Beta Linux with the same plugin.
That browser shows flash at the speed I expect it to be (perhaps even a little
fast) albeit stuttering a little. I'll test in IE and report back.

Comment 4

16 years ago
Isn't bug this a dupe of bug 126139 or bug 104218?
(Reporter)

Comment 5

16 years ago
I would argue that since this was filed first bug 126139 should be a dup of this
(:P) and bug bug 104218 is for Windows and concerns dynamic content (rather than
an animation)
(Reporter)

Comment 6

16 years ago
*** Bug 126139 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Created attachment 85936 [details]
Test Case

Since the URL above (at games.sohu.com) is outdated, this is another test case,
obtained from http://www.sfdt.com/.

Comment 8

16 years ago
setting to future, we will review this at a later date
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 9

16 years ago
Updating URL to one that works (but use the testcase because the xiaoxiaomovie
site is often slow and overloaded).

Comment 10

16 years ago
i see it with flash6.0r29

*** This bug has been marked as a duplicate of 132759 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 11

16 years ago
I am not convinced that this bug is a dup of 132759... It's the wrong platform
and this bug is about performance becomming slower since moz 0.9.8 not about
100% CPU being used (it's not).

Comment 12

16 years ago
Re-opening

Bug 132759 is specific to Flash 6.  There is no flash 6 for linux.
The original report describes a regression wrt speed of Flash 5 and Linux.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 13

16 years ago
please read blizzard's comment #2
resolving as wontfux.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX

Comment 14

16 years ago
marking verif, pls reopen stating a reason, Thx!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.