Incorrect CSS Rendering, black or transparent boxes displayed instead

RESOLVED DUPLICATE of bug 1240800

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1240800
2 years ago
2 years ago

People

(Reporter: daniel.2345, Assigned: kats)

Tracking

({regression})

47 Branch
x86_64
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 unaffected, firefox47 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160205030204

Steps to reproduce:

I think the below 2 issues (A & B) might be connected, that's why I put them together, if I'm incorrect, I'm sorry :(

A. Black boxes Issue

1. Go to http://codepen.io/tholman/full/rxJpdQ
2. Move your mouse a lot, horizontally, vertically
3. See Black boxes flashing

B. Transparent Content (apparently affecting inline CSS)

1. Go to http://forum7.hkgolden.com/view.aspx?type=SW&message=6220646&page=11
2. Explore the content and try highlighting them to make FF render the faded text again (The incorrectly rendered transparent text and images can be found besides the floating emojis)


Actual results:

A. I see black boxes appeared instead of a clear background.

B. I cannot see the desired content until I highlight them using my mouse.


Expected results:

A. No black boxes should have displayed

B. Invisible content should be displayed upon loading the page
(Reporter)

Updated

2 years ago
Component: Untriaged → General
Keywords: css2
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: General → Graphics
Product: Firefox → Core

Updated

2 years ago
Blocks: 1246469

Comment 1

2 years ago
Separate problem B as bug1246469
Comment hidden (obsolete)

Updated

2 years ago
Keywords: css2 → regression

Updated

2 years ago
tracking-e10s: --- → ?

Comment 3

2 years ago
w/ e10s + APZ enabled, the range(Comment 2) is wrong.
No longer blocks: 1180417
Flags: needinfo?(ted.clancy)

Comment 4

2 years ago
Reproduced on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 ID:20160206030207

Regression window(about problem A) w/ e10s+APZ:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=52f3d7379370&tochange=e8ea2a9493da

Comment 5

2 years ago
Via local build:
Last Good: e51ef562f1c5
First Bad: 22b3af8c20b2

Triggered by: 22b3af8c20b2	Kartikaya Gupta — Bug 1178060 - Ensure that if there is a document-level apz-aware event listener on a subdocument, we build the nsDisplaySubdocument item to hold that information. r=tn
Blocks: 1178060
Flags: needinfo?(bugmail.mozilla)

Updated

2 years ago
status-firefox47: --- → affected
Component: Layout: Text → Layout
(Reporter)

Comment 6

2 years ago
Created attachment 8716838 [details]
Since A and B are separated. Here is a proof of the black boxes issue
Thanks, I can reproduce this on Windows. Seems to be related to the event-regions (as the regression range indicates) - I can repro with APZ disabled and layout.event-regions.enabled set to true, but if I disable both APZ and event regions I don't see it.
Assignee: nobody → bugmail.mozilla
Blocks: 1013364
status-firefox46: --- → affected
Flags: needinfo?(bugmail.mozilla)
This is very similar to bug 1161978 but unfortunately the patch on that bug doesn't fix this for me.
See Also: → bug 1161978
Turning on layers.draw-borders and repro'ing the bug does seem to indicate that this is related to layer invalidation. The event regions changes probably just affect the structure of the layer tree and expose a pre-existing bug.
The patch on bug 1240800 *does* appear to fix this issue.
Depends on: 1240800

Updated

2 years ago
Component: Layout → Graphics: Layers
This should be fixed in the feb10 nightly via bug 1240800.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
No longer depends on: 1240800
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1240800
Marking 46 as unaffected based on https://bugzilla.mozilla.org/show_bug.cgi?id=1240800#c29
status-firefox46: affected → unaffected
tracking-e10s: ? → ---
You need to log in before you can comment on or make changes to this bug.