With ReminderFox add-on active: all Toolbar related Drag and Dop fails

RESOLVED WORKSFORME
(Needinfo from 2 people)

Status

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: RainerBielefeldNG, Unassigned, NeedInfo)

Tracking

({regression})

SeaMonkey 2.42 Branch
Unspecified
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Steps how to reproduce with unofficial (from <http://seamonkey.callek.net/contrib/>)  en-US Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0)  Gecko/20100101 Firefox/47.0 Build 20160205232941  (Default Classic Theme) on on German WIN7 64bit:

1. 'Launch Browser → http://www.seamonkey.at/ the only web page what
   is shown' (tab bar is shown, I doubt that this detail is relevant) → 
   In menu View → Show/Hide make Bookmarks toolbar visible if necessary'
2. Click icon at the left end of Location (URL) Toolbar → Drag and Drop
   to bookmarks Toolbar
   Expected: Mouse pointer shows different view related to position at
             Bookmarks toolbar, Releasing mouse button at mouse pointer
             position between 2 bookmarks makes new bookmark appear
   Actual: Mouse pointer keeps "hand + Finger" view anywhere at 
           Bookmarks Toolbar, releasing mouse button at correct position
           does nothing, no new bookmark will appear.

Additional information:
a) regression, worked fine with 2.39 (and may be later, I will check)
b) probably related effect: In step 2when you reach the ">>" at the
   right end of the Bookmarks toolbar the pulldown with additional 
   bookmarks does not appear
(Reporter)

Comment 1

3 years ago
 c) This one is not a simple SeaMonkey Bug, but seems related to (particular?)
   add-ons: Safe mode heals the problem. But the same profile 

d) Already REPRODUCIBLE with inofficial (from 
   <http://seamonkey.callek.net/contrib/>)  
   English  SeaMonkey 2.43a1  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0)  
   Gecko/20100101 Firefox/46.0 Build 20160116041507  (Default Classic Theme) on
   on German WIN7 64bit
c): Reason seems to be caused by a compatibility issue with ReminderFox 2.1.5.4
    Disabling that add-on heals the problem (also for SM 2.43)
    I will contact add-on-author
Whiteboard: [easyconfirm]
(Reporter)

Updated

3 years ago
Version: SeaMonkey 2.44 Branch → SeaMonkey 2.43 Branch
(Reporter)

Comment 2

3 years ago
Probably a ReminderFox problem - let's wait for a comment from RF-author
Summary: Drag and Dop Bookmark from Location bar to Bookmarks Toolbar fails → With ReminderFox add-on active: all Toolbar related Drag and Dop fails
Trying to add the RF authors to the CC. BMO knows two "Tom Mutdosh"es and no fewer than six "Daniel Lee"s, let's hope I found the right one.

Tom:
- If you aren't the author of ReminderFox, please CC your homonym with the help of the BMO autocomplete feature
- If you are, see the above comments
- If you know which "Daniel Lee" is the right one, please add him to the CC list.
Flags: needinfo?(tommut)

Updated

3 years ago
Flags: needinfo?(tommut)

Comment 4

3 years ago
The author and lead dev is Tommut (tommut@gmail.com).

Reminderfox up to 2.1.5.4 makes use of the <statusbar/> which worked with FX/TB and SM with standard releases. 
Deleting that part from an overlay is expected to solve the problem 
(tested with FX developer version: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0 (en-US)).

Will be fixed with next RmFX release.
(Reporter)

Comment 5

3 years ago
Already REPRODUCIBLE with  SeaMonkey 2.42a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) from ~akalla/unofficial/)  Gecko/20100101  Firefox/ 45.0  Build 20160308183715, (Default Classic Theme) on German WIN7 64bit

BTW: SeaMonkey also is affected by the "Impossible to change TABs order" problem mentioned in user ratings of the add-on

(In reply to Günter from comment #4)
> The author and lead dev is Tommut (tommut@gmail.com).
GeminderFox test version already available?
Version: SeaMonkey 2.43 Branch → SeaMonkey 2.42 Branch
(Reporter)

Comment 6

3 years ago
Was still ok with  en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0)from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on German WIN7 64bit. Also ok: "Impossible to change TABs order".

Comment 7

2 years ago
Due to some FX45 code changes Reminderfox was broken with the described problems.
Upcoming Reminderfox version 2.1.5.5 code has some workarounds and should fix the problems.
Please look out for final AMO release/signing.

Comment 8

2 years ago
The ReminderFox team is always right on top of things.  THANKS!
(Reporter)

Comment 9

2 years ago
I installed Reminderfox version 2.1.5.5, first quick test with English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit looks very promising.
(Reporter)

Comment 10

2 years ago
Reminderfox version 2.1.5.5 no longer shows the problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.