Firefox 44 do not correct delete form search history on exit

RESOLVED DUPLICATE of bug 1244525

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1244525
2 years ago
2 years ago

People

(Reporter: Zitronella, Unassigned)

Tracking

({privacy})

44 Branch
x86_64
Windows 7
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8716754 [details]
ff-44.0-DO-NOT-delete-form-search-history-on-exit.gif

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

-Create new Firefox 44 profile
-Options ->Options ->Privacy -> Use custom settings for history ->Keep cookies until i close Firefox AND clear history when firefox closes ->Settings for Clearing History ->"Form &Seach History"
-enter some search words in searchbox and open sarch (in google)
-close firefox
-open firefox
-form and search history are not deleted 


Actual results:

-Form&Search History are not deleted


Expected results:

-Form&Search History should be deleted

See my Attachments for correct behavior in firefox 43.0.4
and uncorrect behavior in firefox 44

PS: on firefox 44: if i close and open firefox again and again, sometimes the form&sarch history is deleted, but on my working profile (where i have some extensions installed) it deletes it never on exit since firefox 44

(only for better demonstration in attachments i created a portable firefox 43.0.4 and 44.0. But the behavior on an installed firefox is the same)
(Reporter)

Updated

2 years ago
Component: Untriaged → Preferences
Keywords: privacy
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
Created attachment 8716755 [details]
ff-43.0.4-delete-form-search-history-on-exit.gif

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244525
You need to log in before you can comment on or make changes to this bug.