Streaming video playback stutters for YouTube HTML5 playback

RESOLVED DUPLICATE of bug 1260611

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED DUPLICATE of bug 1260611
2 years ago
2 years ago

People

(Reporter: Andreas Schiffler, Unassigned)

Tracking

47 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; Touch; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; rv:11.0) like Gecko

Steps to reproduce:

Watch http://digg.com/video/adam-savage-blade-runner-gun on PC with good connection to internet. No/low CPU load. No other applications using GPU.


Actual results:

Video playback is "glitchy" and stutters frequently during the playback.


Expected results:

Video playback is smooth and has no issues.
(Reporter)

Comment 1

2 years ago
Created attachment 8717071 [details]
YouTube-HTML5player-debugInfo.txt
(Reporter)

Comment 2

2 years ago
Video capture of the issue is available (can't upload the 120MB file).
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 3

2 years ago
Created attachment 8717075 [details]
dxdiag.txt

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Comment 4

2 years ago
WFM with FF44/47.
(Reporter)

Comment 5

2 years ago
Here is the video capture that shows the stuttering: http://www.ferzkopp.net/Videos/FF-YouTubeHtml5-VideoPlaybackIssues-19s-and-35s-intoClip.mp4
(Reporter)

Comment 6

2 years ago
Version is 44.0.1 - Build identifier: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Comment 7

2 years ago
Can confirm this.

It only seems to happen in fullscreen for me. This is another video very the problem seems to be even more prominent https://www.youtube.com/watch?v=QzVGf-K2heg  

I have updated to the latest Firefox Beta (45.0b5) and Intel HD520 driver beta (15.40.18.4380) without any change in behavior. 

Microsoft Internet Explorer and Edge do not seem to exhibit the same problem.
(Reporter)

Comment 8

2 years ago
Still happens to me in FF 45.0 with pretty much all streaming videos (Facebook embedded stuff, YouTV.de) in windowed and fullscreen modes. Very annoying (aka I am about to switch default browser settings).
(In reply to Andreas Schiffler from comment #5)
> Here is the video capture that shows the stuttering:
> http://www.ferzkopp.net/Videos/FF-YouTubeHtml5-VideoPlaybackIssues-19s-and-
> 35s-intoClip.mp4

Similar to bug 1236112. Can you try the video link in bug 1236112 comment 0?
Flags: needinfo?(aschiffler)

Comment 10

2 years ago
That is exactly how it looks like for me
Let's wait for bug 1236112 to see if it also fixes the problem here.
Status: UNCONFIRMED → NEW
Depends on: 1236112
Ever confirmed: true
(Reporter)

Comment 12

2 years ago
Yes, I see the same jitters as shown in the video of bug 1236112/comment 0 as well. I tried https://www.youtube.com/watch?v=SGP6Y0Pnhe4 (1080p, 60fps source) and jitters started 10secs into the playback. Jitters seem worse on lower resolutions actually: 480@30 seems worse than 720@60 seems worse than 1080@60 (just a hunch after watching the video at different speeds for a few minutes).
Flags: needinfo?(aschiffler)
Is it still reproducible?
Patch from bug #1236112 landed and could fixed this.
Flags: needinfo?(aschiffler)
(Reporter)

Comment 14

2 years ago
Yes - 100% repro of jitters using the previous link (https://www.youtube.com/watch?v=SGP6Y0Pnhe4) link after about 22sec into the playback. I am running FF 45.0.2. Let me know if there is a way to collect telemetry during playback.
Flags: needinfo?(aschiffler)
Sounds to me like bug 1260611 to me. Is it fixed in this build:

> use-a-queue-for-recycling 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e739bc67de5
(Reporter)

Comment 16

2 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #15)
> Sounds to me like bug 1260611 to me. Is it fixed in this build:
> 
> > use-a-queue-for-recycling 
> > https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e739bc67de5

If you get me a binary for "this build", I'd be happy to try it out.
(In reply to Andreas Schiffler from comment #16)
> If you get me a binary for "this build", I'd be happy to try it out.

You need to click around that page to get to the build. The fix should be in nightly now. Is your issue still reproducible?

Comment 18

2 years ago
i dont understand how to remove them
Priority: -- → P2

Comment 19

2 years ago
(In reply to Laketaweston from comment #18)
> i dont understand how to remove them

Nighty can be downloaded here: https://nightly.mozilla.org/
(Reporter)

Comment 20

2 years ago
Seems fixed. Issue does not repro on Nightly 49.0a1 (2016-05-20) against previous video (https://www.youtube.com/watch?v=SGP6Y0Pnhe4) after multiple minutes of playback at different stream qualities and playback speeds.

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Youtube]
Mass change P2 -> P3
Priority: P2 → P3
Anthony, do we need to backport something here, given comment 20?
platform-rel: ? → +
Flags: needinfo?(ajones)
(In reply to Andrew Overholt [:overholt] from comment #22)
> Anthony, do we need to backport something here, given comment 20?

My understanding is that this is fixed in 47. Let me know if that is not the case.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(ajones)
Resolution: --- → DUPLICATE
Duplicate of bug: 1260611
You need to log in before you can comment on or make changes to this bug.