Cut-paste error with Japanese text

VERIFIED DUPLICATE of bug 108029

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 108029
16 years ago
16 years ago

People

(Reporter: Dennis E. VanHoey, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020516

Japanese text, (and probably just about any character set) when cut from browser
and pasted is translated with question marks.
This happens repeatedly with Appleworks 6.2, notepad, Word 98, etc.. (Carbon &
classic applications), however if the same page is pasted into TextEdit,
stickies, etc.. (All cocoa applications) the text is pasted correctly.

Reproducible: Always
Steps to Reproduce:
1.cut text and paste into Appleworks or any carbon application
2.
3.

Actual Results:  Japanese text is rendered in question marks

Expected Results:  Japanese text should be rendered correctly.

You can work around this by pasting to a cocoa application and then recopying
from that application before pasting to a carbon app.

Comment 1

16 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1). I accessed
[http://www.ntv.co.jp/ghibli/], ensured the correct character coding was in use
(Shift-JIS), copied some of the Japanese text, and pasted it into BBEdit 6.1.2,
with complete success.

Dennis, can you still reproduce the problem using a current build? If so, please
provide more detailed information, including exact URL's.
(Reporter)

Comment 2

16 years ago
Yes, I can still reproduce them, and make them go away too.

Bi-lingual setup:
          These settings allow you to read and write japanese characters with
english 
          menus and dialogs
Settings: Keyboard Menu -> <kotoeri>,  U.S.
          Languages ->First English, Second <japanese>
          Script Behaviors ->Roman

Single language setup:


(Reporter)

Comment 3

16 years ago
Yes, I can still reproduce them, and make them go away too.


Mostly English with some Japanese:
          These settings allow you to read and write japanese characters with
          english menus and dialogs. It is only in this set up that the 
          cut/paste error occurs *only* when pasting to carbon apps. 
System Pref. Settings: 
          Keyboard Menu -> <kotoeri>,  U.S.
          Languages ->First English, Second <nihongo>
          Script Behaviors ->Roman
Mozilla Settings: 
          Character Coding-> Japanese (shift_jis)
          Languages -> either ja, en-us  or en-us, ja
          URLS: Any, examples (www.yahoo.co.jp, www.asahi.co.jp, 
          www.nhk.co.jp, etc...)


Mostly Japanese with some English:
          Using these settings eliminate the error, but this requires a reboot
          to reset all applications.
System Pref. Settings: 
          Keyboard Menu -> <kotoeri>, U.S.
          Languages -> First <nihongo>, Second English
          Script Behavior -> <nihongo>
Mozilla Settings: 
          Character Coding-> Japanese (shift_jis)
          Languages -> either ja, en-us  or en-us, ja


Software/System versions used:
          Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc1) Gecko/20020417
          Mac OS X 10.1.4
          Appleworks 6.2.4
          BBedit 6.1.2
          Textedit 1.1 v174
          Stickies 2.0 v2.0


Example results with error & no error from http://www.nhk-grp.co.jp/index.html

NHK???????????

??????NHK?????????????????????????
???????????????????????????????????????????????????????????????
????????????????

このサイトはNHKグループ関連・関係団体が共同で運営するサイトです。
会社概要、経営情報、採用案内などのほかにショッピングやイベント、セミナーの最新情
報などもとりそろえて皆様をお待ちしております。
どうぞ、ごゆっくりご覧ください。

Comment 4

16 years ago
Reassigning to Internationalization.

Dennis, can you tell us, step by step, what actions you took that exhibited the
problem? List what application you were in, what you copied, and what
application you pasted it into.
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: doron → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → kasumi
(Assignee)

Comment 5

16 years ago
kasumi: can you confirm this bug?
reporter: do you know when you start seeing this bug? Is this regression?

cc ftang and nhotta

Comment 6

16 years ago
> System Pref. Settings: 
>           Keyboard Menu -> <kotoeri>,  U.S.
>           Languages ->First English, Second <nihongo>
>           Script Behaviors ->Roman
Mozilla depends on the default language setting. With above setting, Japanese
characters turn to question marks (bug 108029).

> System Pref. Settings: 
>           Keyboard Menu -> <kotoeri>, U.S.
>           Languages -> First <nihongo>, Second English
>           Script Behavior -> <nihongo>
Copy/Paste works for Japanese characters with above setting as you mentioned in
comment #3.

Mark as dup of bug 108029.

*** This bug has been marked as a duplicate of 108029 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
tested on 2002-04-22-05-1.0.0 using Stickies 2.0(v2.0)
I can't reproduce.
Settings: Keyboard Menu -> <kotoeri>
          Languages ->First <japanese>, Second English
          

Comment 8

16 years ago
Duped 108029 is fixed/Verified. Therefore change marking.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.