Menu is popping up on wrong monitor

RESOLVED DUPLICATE of bug 1240533

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 1240533
2 years ago
2 years ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

({regression})

46 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox45 unaffected, firefox46 wontfix, firefox47 fixed)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20100101

Steps to reproduce:

In both Nightly and Aurora the popup menu appears on the wrong monitor. I have two displays, one is primary and that is where I open Firefox. The popup menu appears in the secondary display only when Firefox in the primary display is about more than 2/3 of the screen starting from the left.

I seem to recall I had a similar issue before and it was fixed (not sure if I reported it or someone else), but I can't find it.

I'm using Windows 7 x64 at 120 dpi.

I ran a bisect to see when this started happening in aurora but it didn't narrow it down to a single changeset.



Actual results:

mozregression --bits 32 --good 7ede46ba62979809bafb3c1507745a4eeaec1c57 --bad f19a31a82ae36283b82d36a0cb2f4264a8356787 --repo mozilla-aurora

 3:06.41 LOG: MainThread Bisector INFO Last good revision: 3bfa5bc61b626761d487b45c170b115259f69d6b
 3:06.41 LOG: MainThread Bisector INFO First bad revision: b9a803752a2cb143582e6665ed3fb679eebf60b3
 3:06.41 LOG: MainThread Bisector INFO Pushlog: https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=3bfa5bc61b626761d487b45c170b115259f69d6b&tochange=b9a803752a2cb143582e6665ed3fb679eebf60b3



Expected results:

The popup should be on the screen I'm using Firefox on.
(Reporter)

Updated

2 years ago
Version: 38 Branch → Trunk

Updated

2 years ago
Component: Untriaged → Menus

Comment 1

2 years ago
This pushlog is too huge, could you run mozregress without "--repo mozilla-aurora" to have a pushlog from m-i.
Flags: needinfo?(raysatiro)
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> This pushlog is too huge, could you run mozregress without "--repo
> mozilla-aurora" to have a pushlog from m-i.

Sure.
mozregression --bits 64 --good e790bba372f14241addda469a4bdb7ab00786ab3 --bad d1a54ae63da7ebc4bc1eeb5b613e8ec29bfcb80a
 8:39.77 INFO: Narrowed inbound regression window from [98756a36, ecd38844] (3 revisions) to [98756a36, a9f9b36c] (2 revisions) (~1 steps left)
 8:39.77 INFO: Oh noes, no (more) inbound revisions :(
 8:39.78 INFO: Last good revision: 98756a36223c1a2b51cd0368736b728429038caf
 8:39.78 INFO: First bad revision: a9f9b36c1a2eec7626e6b749e46ab0a8bf3323e2
 8:39.78 INFO: Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98756a36223c1a2b51cd0368736b728429038caf&tochange=a9f9b36c1a2eec7626e6b749e46ab0a8bf3323e2

So this probably has something to do with the fixes for 890156. I'm going to list that as blocking; I apparently don't have a way to needinfo anyone? This needs info from jfkthame
Flags: needinfo?(raysatiro)
(Reporter)

Updated

2 years ago
Blocks: 890156
Flags: needinfo?(jfkthame)

Updated

2 years ago
status-firefox45: --- → unaffected
status-firefox46: --- → affected
status-firefox47: --- → affected
tracking-firefox46: --- → ?
tracking-firefox47: --- → ?
Keywords: regression

Updated

2 years ago
Version: Trunk → 46 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → DUPLICATE
Duplicate of bug: 1240533

Comment 4

2 years ago
flags removed because of duped.
tracking-firefox46: ? → ---
tracking-firefox47: ? → ---
status-firefox46: affected → wontfix
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.