Makes thunderbird stall when opening mail for 30 seconds

RESOLVED DUPLICATE of bug 1192209

Status

Calendar
Provider: ICS/WebDAV
RESOLVED DUPLICATE of bug 1192209
2 years ago
2 years ago

People

(Reporter: Harald Oehlmann, Unassigned)

Tracking

Lightning 4.0.5.1

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160205155049

Steps to reproduce:

Lightning is Installed and has 11 calenders on a samba share and 1 local calender.
You wait 3 hours and compose a mail in Thunderbird. You type your mail text.

(Why this bug here:
This is a long standing Thunderbird bug and many users report that it only appears in combination with lightning:
https://bugzilla.mozilla.org/show_bug.cgi?id=942610
)
(System:
Windows 10 64 bit GER, Thunderbird 38.5.1 32 bit
)


Actual results:

Tunderbird new mail window pauses for 30 seconds before displaying keystrokes.
Within this time, the keystrokes may arrive in the main Thunderbird window, which gets the focus for 20 seconds. The focus is automatically switched back.
Keystrokes for the mail text may cause commands in the Thunderbird main window like "d"-> delete or "a" -> archive. Those keystrokes do not appear in the composer window after 30 seconds.


Expected results:

No delay.

Comment 1

2 years ago
Can you please check whether this is a duplicate of bug 1192209?
Flags: needinfo?(harald.oehlmann)
(Reporter)

Comment 2

2 years ago
Maybe yes.

I have checked, if memory need increases.
I looked each hour into the task manager.
At the end of the day, the delay apreared, at around 600MB.
Here is the log:
8:00 219MB
10:00 300MB
13:00 500MB
15:00 690MB <- here, the delay gets anoying
17:00 712MB

Thank you,
Harald
Flags: needinfo?(harald.oehlmann)

Comment 3

2 years ago
Maybe the point when it get's annoying is when your system starts to swap. What refresh rate do you have configured for the calendars on the share? Does it reduce the impact if you reduce the rate?
Flags: needinfo?(harald.oehlmann)
(Reporter)

Comment 4

2 years ago
Thank you for the question.
I have modified: Refresh time from 5 to 15 Minuites for all calendars.
The grows of memory is less:
9:00 174MB
10:00 217MB
11:00 207MB
14:00 291MB
16:00 301MB
So after 7 hours, the size was 300MB and not 690MB as yesterday.
The delay effect is not remarkable jet.

So in consequence, we may state:
- the anoyence degree depneds on required memory and starts at 700MB
- the memory growth speed depends (also) on the refresh rate of the calenders

Thank you,
Harald
Flags: needinfo?(harald.oehlmann)

Comment 5

2 years ago
The threshold when it impact the UX probably correlates to the memory available at a system. Given to commens 2 and 4 I mark this as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1192209

Updated

2 years ago
Component: General → Provider: ICS/WebDAV
You need to log in before you can comment on or make changes to this bug.