44.0.1 issues with @font-face

RESOLVED DUPLICATE of bug 1244693

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 1244693
2 years ago
2 years ago

People

(Reporter: martin scheidegger, Unassigned)

Tracking

({regression})

44 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160205155049

Steps to reproduce:

calling www.swipala.com


Actual results:

The menu font as well as h1,h2,3,h4 are not displayed in the correct font. Version 43.x displays properly.  The absolutely, absolutely weird thing is: when renaming the font-family in @font-face, the fonts will show! But this - of course! - will not work in all other browsers. Extremely weird.


Expected results:

The fonts should have been displayed like in all other browsers...

Comment 1

2 years ago
I see the example works in 45.0b4, not works in 44.0, 46.0a2 (2016-02-10) and 47.0a1 (2016-02-09).
Component: Untriaged → Layout: Text
Product: Firefox → Core
The font http://www.swipala.com/fonts/Giorgio.woff used by that site has errors in its OpenType layout tables. Firefox 44 applies stricter validation to webfonts, which causes it to be rejected.

(See bug 1244693 for more details; and check the web console for font-related error messages when webfonts fail to load.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244693

Comment 3

2 years ago
No, I seen the font be apply properly with a lot of font error messages ("downloadable font: Layout: Failed to parse ...."), and apply properly with no error in Fx45b4, and also may not applied with same error messages in some builds.


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=15104d2224f4d1c794994941e880d616cf9aa486&tochange=5baceaa01feee58e5dee795f9ef3bd2a596c8448
Status: RESOLVED → UNCONFIRMED
Keywords: regression
Resolution: DUPLICATE → ---
(In reply to YF (Yang) from comment #3)
> No, I seen the font be apply properly with a lot of font error messages
> ("downloadable font: Layout: Failed to parse ...."), and apply properly with
> no error in Fx45b4, and also may not applied with same error messages in
> some builds.

As expected. In releases prior to FF44, the GDEF/GPOS/GSUB tables would be discarded due to the errors that OTS is finding ("downloadable font: Layout: Failed to parse", etc); so the font will render but any OpenType layout features (kerning, ligatures, etc) will be missing.

In FF44, and in current Aurora and Nightly builds, those errors cause the font to be rejected altogether.

And in FF45beta (and Beta/Release builds going forward for FF45+), validation of the GDEF/GPOS/GSUB tables is disabled and so the font will be loaded (and no error messages are shown, because those tables bypass the validator completely).

Nightly/Aurora continue to apply stricter validation and reject erroneous fonts, so that developers who test with these builds can discover and fix their broken resources.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244693

Comment 5

2 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #4)
> (In reply to YF (Yang) from comment #3)
> > No, I seen the font be apply properly with a lot of font error messages
> > ("downloadable font: Layout: Failed to parse ...."), and apply properly with
> > no error in Fx45b4, and also may not applied with same error messages in
> > some builds.
> 
> As expected. In releases prior to FF44, the GDEF/GPOS/GSUB tables would be
> discarded due to the errors that OTS is finding ("downloadable font: Layout:
> Failed to parse", etc); so the font will render but any OpenType layout
> features (kerning, ligatures, etc) will be missing.
> 
> In FF44, and in current Aurora and Nightly builds, those errors cause the
> font to be rejected altogether.
> 
> And in FF45beta (and Beta/Release builds going forward for FF45+),
> validation of the GDEF/GPOS/GSUB tables is disabled and so the font will be
> loaded (and no error messages are shown, because those tables bypass the
> validator completely).
> 
> Nightly/Aurora continue to apply stricter validation and reject erroneous
> fonts, so that developers who test with these builds can discover and fix
> their broken resources.
> 
> *** This bug has been marked as a duplicate of bug 1244693 ***

Thanks for your explanation, I can understand it now.
(Reporter)

Comment 6

2 years ago
Thank you all for caring about the issue! In the meantime, I will replace the fonts with working samples. So the issue is not replicable anymore under swipala.com. Thanks!
You need to log in before you can comment on or make changes to this bug.