Support HTML/XML preview for HTTP responses

RESOLVED DUPLICATE of bug 1353319

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1353319
3 years ago
11 months ago

People

(Reporter: Honza, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(firefox47 affected)

Details

User Story

Developers want to see the HTML response of HTTP requests in a formatted way to be able to easily read the contents. This is especially useful for error responses, which are not output on the website.
This is a follow up for bug 1211525

It should be possible to preview XML/HTML HTTP responses as nicely rendered markup (inside the Response tab).

Honza

Updated

3 years ago
Depends on: 1240494
Priority: -- → P2
See Also: → 1262796
Summary: Support XML preview for HTTP responses → Support HTML/XML preview for HTTP responses
Removing that feature from the network tab was really frustrating. Debugging API errors from Django got a lot harder since 500s come with a HTML stacktrace (when debug is set to True). That should facilitate development but currently is actually making it harder since we have to copy the HTML from the Response pane into a .html file an then open it.
User Story: (updated)
Comment hidden (me-too)
Comment hidden (me-too)

Comment 5

2 years ago
When will be this feature available ? Why it has been removed ? Need to use Chrome to see Laravel / .net answer in rendered HTML.
It was removed in bug 1350229 due to the incorrect assumption that it duplicates functionality. It will be added back again in bug 1353319. Note that this report report is different, because it asks to add the HTML preview to the console.
 
Sebastian
See Also: → 1353319
bug 1353319 seems implemented this feature.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353319

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.