Closed Bug 1247640 Opened 4 years ago Closed 2 years ago

Sending a synchronous message from nsIContentPolicy.shouldLoad() causes drawing issues on Restore Session page

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox47 --- affected

People

(Reporter: gaubugzilla, Unassigned)

References

Details

Attachments

(1 file)

Steps to reproduce:

1. Change xpinstall.signatures.required preference to false and install attached extension (minimal testcase distilled from Adblock Plus, does nothing beyond registering a content policy in all processes and sending a synchronous message from nsIContentPolicy.shouldLoad()).
2. While Firefox is running, make a copy of sessionstore-backups/recovery.js file in the Firefox profile.
3. Close Firefox.
4. Restore your copy of sessionstore-backups/recovery.js and replace sessionCheckpoints.json file in the Firefox profile by the following:

> {"profile-after-change":true,"final-ui-startup":true}

5. Start Firefox again.

Steps 2-4 can be replaced by crashing Firefox.

Expected results:

Session Restore page shows up saying "Well, this is embarrassing" and offering you to restore the previous session. Close and Restore buttons are visible under the list.

Actual results:

50% of the time the Close and Restore buttons won't be visible for me (Firefox 47.0a1 nightly from 2016-02-11 on OS X 10.11, issue was originally reported for Firefox 45.0a2 aurora on Windows 10). Resizing the browser window or moving the mouse over the buttons makes the buttons appear.

Unfortunately, I was unable to reproduce the issue with an exact copy of about:sessionrestore in an extension, so I was unable to narrow this down further.
We worked around this issue in Adblock Plus (https://hg.adblockplus.org/adblockplus/rev/637c6ebb90c1), this change will be part of the Adblock Plus 2.7.1.4137-beta development build as well as Adblock Plus 2.7.2 on February 23.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.