Bookmark panel layout overflows when expanding folder list

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
P3
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8718674 [details]
Screenshot

1) Create a new profile
2) Click the bookmark star, show panel.
3) Click the [v] expander (to show the full list of available folders)

Glitch: The list expands beyond the width of the panel, and the folder list can't be collapsed again. (Either the tree view needs to fit inside the panel's width, or the panel needs to grow to show the full tree view). You can at least close the panel to have the folder list revert to being collapsed.

I can reproduce in both Nightly and Firefox 44. Although, oddly, it sometimes starts working (or, at least, the default panel width is significantly wider, such that expanding the list doesn't need to overflow. Perhaps the code that determines the needed panel width is glitchy?)
Priority: -- → P3
(Reporter)

Comment 1

2 years ago
(Bug 1247824 is vaguely related, but probably different.)
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
I tried to check if bug 1247824 made a difference and couldn't reproduce this anymore. But then I checked the latest nightly without bug 1247824 being fixed and couldn't reproduce this either. Are you still seeing this?
Flags: needinfo?(dolske)
(Reporter)

Comment 3

2 years ago
Hmm, nope, seems to be fixed now. I can easily reproduce this on earlier Nightlies, and mozregression says it got fixed between the 9th and 10th. So it seems likely that bug 1247824 fixed this (or else something else coincidentally landed in that same range). Nice, 2-for-1.
Assignee: bmcbride → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dolske)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.