Unable to display wiki web calendars from OS X Server

RESOLVED DUPLICATE of bug 939619

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 939619
2 years ago
2 years ago

People

(Reporter: lelievre, Unassigned)

Tracking

44 Branch
Unspecified
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8718802 [details]
Screen shot comparing Safari & Firefox

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/601.4.4 (KHTML, like Gecko) Version/9.0.3 Safari/601.4.4

Steps to reproduce:

Since I use OS X Server 4.02 (i.e. since June 2014, today I use Server 5.0.15), Firefox still does not display wiki calendars while they are displayed correctly in Safari and Aviator.

Steps to Reproduce:
1. Install OS X Server
2. Select Calendars, set permissions to all users, all networks, turn the Calendars service On
3. Select Wikis, set permissions to all users, turn the Wikis service On
4. Select Groups, create a Group
5. Create a Group Wiki from the Group settings
6. Open Firefox, enter the URL of the wiki and activate the Calendar option.



Actual results:

When loading the web page, banner, menus, etc. are displayed correctly except the list of calendars. See screen shot showing the same page loaded with Safari 9.0.3 (11601.4.4) and Firefox 44.0.2 on a Mac Pro (Late 2013) running OS X 10.11.3 (15D21).


Expected results:

The page should present a list of calendars and the corresponding events. This is what one gets with Safari and Aviator.
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → All

Comment 1

2 years ago
Any live testcase?

Updated

2 years ago
Severity: critical → normal
(Reporter)

Comment 2

2 years ago
Unfortunately, I cannot put my server on the Internet — it contains private data from my company.
But may be someone from this Apple forum may provide a live test case: 

https://discussions.apple.com/thread/6879726?start=0&tstart=0

Comment 3

2 years ago
I tried to search some live demos on Google, but all OS X Server I found are from schools with private credentials.
(Reporter)

Comment 4

2 years ago
I have contacted people to see whether I could find a way to put a demo server on the Internet. Will see…

Comment 5

2 years ago
Or rceating a guest account with limited rights, then send credentials by email.
(Reporter)

Comment 6

2 years ago
Yes, but the server is only accessible from the Intranet. The easiest is certainly to configure a dummy server accessible from the Internet and I'm going to look for a way to do so.

Comment 7

2 years ago
Related / duplicate of bug 939619?

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939619
You need to log in before you can comment on or make changes to this bug.