Closed Bug 1248083 Opened 7 years ago Closed 7 years ago

Permaorange starting at 10am 2016-02-12 Android 4.3 testSessionHistory | Menu is open -

Categories

(Firefox for Android Graveyard :: Testing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: intermittent-failure)

+++ This bug was initially created as a clone of Bug #1144879 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=21647827&repo=mozilla-inbound

10:36:01     INFO -  TEST-PASS | testSessionHistory | Menu is not open -
10:36:01     INFO -  TEST-PASS | testSessionHistory | The overflow menu button is enabled -
10:36:01     INFO -  TEST-PASS | testSessionHistory | The overflow menu button is visible - 0 should equal 0
10:36:01     INFO -  TEST-PASS | testSessionHistory | Waiting for menu to open. -
10:36:12  WARNING -  TEST-UNEXPECTED-FAIL | testSessionHistory | Menu is open -
10:36:25     INFO -  0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testSessionHistory | Menu is open -
10:36:25     INFO -  	at junit.framework.Assert.fail(Assert.java:50)
10:36:25     INFO -  	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:128)
10:36:25     INFO -  	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:150)
10:36:25     INFO -  	at org.mozilla.gecko.tests.helpers.AssertionHelper.fAssertTrue(AssertionHelper.java:98)
10:36:25     INFO -  	at org.mozilla.gecko.tests.components.AppMenuComponent.pressMenuItem(AppMenuComponent.java:176)
10:36:25     INFO -  	at org.mozilla.gecko.tests.components.AppMenuComponent.pressMenuItem(AppMenuComponent.java:196)
10:36:25     INFO -  	at org.mozilla.gecko.tests.helpers.NavigationHelper$2.run(NavigationHelper.java:85)
10:36:25     INFO -  	at org.mozilla.gecko.tests.helpers.WaitHelper.waitForPageLoad(WaitHelper.java:95)
10:36:25     INFO -  	at org.mozilla.gecko.tests.helpers.NavigationHelper.goForward(NavigationHelper.java:82)
10:36:25     INFO -  	at org.mozilla.gecko.tests.testSessionHistory.testSessionHistory(testSessionHistory.java:31)
10:36:25     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
10:36:25     INFO -  	at java.lang.reflect.Method.invoke(Method.java:525)
10:36:25     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
10:36:25     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
10:36:25     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
10:36:25     INFO -  	at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
10:36:25     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:134)
10:36:25     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:115)
10:36:25     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:133)
10:36:25     INFO -  	at junit.framework.TestResult.run(TestResult.java:118)
10:36:25     INFO -  	at junit.framework.TestCase.run(TestCase.java:124)
10:36:25     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
10:36:25     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
10:36:25     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
10:36:25     INFO -  	at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:60)
10:36:25     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
10:36:25  WARNING -  TEST-UNEXPECTED-FAIL | testSessionHistory | Exception caught - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testSessionHistory | Menu is open -
Not too many ways to imagine this happening that are good things - every single run since sometime around 10am has failed this way, on both mozilla-inbound and fx-team.
Summary: Android 4.3 testSessionHistory | Menu is open - → Permaorange starting at 10am 2016-02-12 Android 4.3 testSessionHistory | Menu is open -
See Also: → 1236194
Logcats from the failed jobs show SSLExceptions, which are not found in logcats from successful (earlier) jobs:

02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: Error
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: javax.net.ssl.SSLException: Connection closed by peer
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at org.apache.harmony.xnet.provider.jsse.NativeCrypto.SSL_do_handshake(Native Method)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl.startHandshake(OpenSSLSocketImpl.java:398)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpConnection.setupSecureSocket(HttpConnection.java:209)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpsURLConnectionImpl$HttpsEngine.makeSslConnection(HttpsURLConnectionImpl.java:478)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpsURLConnectionImpl$HttpsEngine.connect(HttpsURLConnectionImpl.java:442)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpEngine.sendSocketRequest(HttpEngine.java:290)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpEngine.sendRequest(HttpEngine.java:240)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpURLConnectionImpl.getResponse(HttpURLConnectionImpl.java:282)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpURLConnectionImpl.getInputStream(HttpURLConnectionImpl.java:177)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at libcore.net.http.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:271)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at org.mozilla.gecko.SuggestClient.query(SuggestClient.java:89)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at org.mozilla.gecko.home.BrowserSearch$SearchEngineSuggestionAsyncLoader.loadInBackground(BrowserSearch.java:959)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground$532ebdd5(Unknown Source)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at android.support.v4.content.AsyncTaskLoader$LoadTask.doInBackground$42af7916(Unknown Source)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at android.support.v4.content.ModernAsyncTask$2.call(Unknown Source)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at java.util.concurrent.FutureTask.run(FutureTask.java:234)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)
02-12 10:57:55.001  2120  2240 E GeckoSuggestClient: 	at java.lang.Thread.run(Thread.java:841)
This should be caused by the switchboard experiment that creates a longer overflow menu; See bug 1234693 and bug 1247366. The patch in bug 1247366 should fix that.
(In reply to Sebastian Kaspari (:sebastian) from comment #3)
> This should be caused by the switchboard experiment that creates a longer
> overflow menu; See bug 1234693 and bug 1247366. The patch in bug 1247366
> should fix that.

Yes, this sounds like this issue. I asked miles to revert this change Friday night EST, and it looks like it stopped after that.

More fundamentally, this problem is bug 1247324. We should not let switchboard server config changes introduce failures in automation.
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: 1247324
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.