Status

RESOLVED DUPLICATE of bug 109044
17 years ago
3 years ago

People

(Reporter: johann.petrak, Assigned: dveditz)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I am using 0.9.8 release (2002020415/linux).
Several XPIs I tried to install didnt work and since the symptoms are
the same for all of them I suspect this to be mozilla problem.
One of the XPIs that dont work is the Asturian language pack for 
0.9.8 (see URL).

The install.log file contains an error -239, whatever that might
be for registerin (is there a list of error codes somewhere?)

Another problem that maybe needs another bug is that 
*no indication* that something went wrong with the install
was given to me!

http://ftp.mozilla.org/pub/mozilla/l10n/lang/moz0.98/langastas.xpi  --  02/11/20
-------------------------------------------------------------------------------

     ** initInstall: platformNode=unix
     Paquete de Llingua Asturiana (ast-AS)
     -------------------------------------

     ** initInstall: 0
     ** fProgram: /home/johann/Install/mozilla/
     ** addDirectory() returned: 0
     [1/21]     Installing: /home/johann/Install/mozilla/chrome/ast-AS.jar
     [2/21]     Installing: /home/johann/Install/mozilla/chrome/ast-win.jar
     [3/21]     Installing: /home/johann/Install/mozilla/chrome/ast-unix.jar
     [4/21]     Installing: /home/johann/Install/mozilla/chrome/ast-mac.jar
     [5/21]     Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/

     Install **FAILED** with error -239

     Install **FAILED** with error -239
     ** performInstall() returned: -239
     Finished Installation  02/11/2002 08:04:36

Same problem with the uabar from mozdev:

     [6/6]      Register Content: resource:/chrome/uabar/content/

     Install **FAILED** with error -239

     Install **FAILED** with error -239

Comment 1

17 years ago
dup of bug 109044?

*** This bug has been marked as a duplicate of 109044 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
The content-type for langastas.xpi is showing as "application/x-xpinstalli".  I
believe it should be "application/x-xpinstall".  Could this be a reason?

When I drag this xpi onto my browser from my desktop, I am able to install
successfully.

-------------------------------------------------------------------------------
file:///C:/Documents%20and%20Settings/jimmylee/Desktop/langastas.xpi  -- 
05/21/2002 14:50:34
-------------------------------------------------------------------------------

     ** initInstall: platformNode=win
     Paquete de Llingua Asturiana (ast-AS) (version 0.9.8.2002020409)
     -------------------------------------

     ** initInstall: 0
     ** fProgram: C:\Program Files\Netscape\Netscape\
     ** addDirectory() returned: 0
     [1/22]	Installing: C:\Program Files\Netscape\Netscape\chrome\ast-AS.jar
     [2/22]	Installing: C:\Program Files\Netscape\Netscape\chrome\ast-win.jar
     [3/22]	Installing: C:\Program Files\Netscape\Netscape\chrome\ast-unix.jar
     [4/22]	Installing: C:\Program Files\Netscape\Netscape\chrome\ast-mac.jar
     [5/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/global/
     [6/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/communicator/
     [7/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/messenger/
     [8/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/messenger-smime/
     [9/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/editor/
     [10/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/navigator/
     [11/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/necko/
     [12/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/mozldap/
     [13/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/cookie/
     [14/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/wallet/
     [15/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/content-packs/
     [16/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/help/
     [17/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/pippki/
     [18/22]	Register Locale: jar:resource:/chrome/ast-AS.jar!/locale/ast-AS/pipnss/
     [19/22]	Register Locale:
jar:resource:/chrome/ast-win.jar!/locale/ast-AS/global-platform/
     [20/22]	Register Locale:
jar:resource:/chrome/ast-win.jar!/locale/ast-AS/communicator-platform/
     [21/22]	Register Locale:
jar:resource:/chrome/ast-win.jar!/locale/ast-AS/navigator-platform/
     [22/22]	Register Locale: jar:resource:/chrome/ast-win.jar!/locale/ast-AS/messenger-mapi/
     ** performInstall() returned: 0

     Install completed successfully  --  05/21/2002 14:50:34
(Assignee)

Comment 4

17 years ago
That must be a recent problem, Jimmy. The -239 issues are Linux-only, and only
affect certain systems. It really is a dupe of bug 109044. The issue raised by

  Another problem that maybe needs another bug is that 
  *no indication* that something went wrong with the install
  was given to me!

has been fixed as part of other bugs.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.