Status

()

defect
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: emk, Assigned: u408661)

Tracking

unspecified
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

(Whiteboard: [necko-active], URL)

Attachments

(1 attachment, 1 obsolete attachment)

58 bytes, text/x-review-board-request
mcmanus
: review+
Details
(Reporter)

Description

3 years ago
Chrome will drop the support on May 15th.
(Reporter)

Updated

3 years ago
Blocks: 912549
(Reporter)

Comment 1

3 years ago
Posted patch patch (obsolete) — Splinter Review
https://treeherder.mozilla.org/#/jobs?repo=try&revision=12494301a0a9&selectedJob=16708768
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #8719237 - Flags: review?(mcmanus)
Comment on attachment 8719237 [details] [diff] [review]
patch

not yet.. there is still plenty of spdy usage
Attachment #8719237 - Flags: review?(mcmanus) → review-
we will do this eventually, but not now. definitely on the radar
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Duplicate of this bug: 1271145

Comment 5

3 years ago
Chrome removed support for spdy/3.1. Only http/2 supported now. Firefox should do the same, irrelevant of how much spdy/3.1 usage there is. We don't want to be stuck having to support and maintain old spdy/3.1 code for long.
(Reporter)

Comment 6

3 years ago
Reopening because :mcmanus suggested reconsidering (bug 1248198 comment #23).
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
we're down to ~2% spdy usage compared to 20% when this was filed. I think its ok to do in a ride the trains fashion now. NPN is a bit more complicated - it is used with h2, and it has implications for false start.. so let's make sure we deal with that as a separate topic.

nick - I think you've wanted this for a while. Would you do a patch for gecko-50 that flips the pref to off (the tests should set it on explicitly so they are probably ok - but make sure) and then a code removal patch for 51? The pref flip should be a different bug.

To whatever extent people want to rename remaining code things to h2 from spdy let's do that in a different patch. I'm agnostic on it.

thanks!
Flags: needinfo?(hurley)
(Assignee)

Comment 8

3 years ago
*insert high-pitched squeeing noise here*

I will absolutely take this. You're right, I've been itching to do this at *least* since Orlando, and even more since London, when I looked at the telemetry, too. Just forgot to bring it up :)

I'll file another bug for the pref-flip, and probably another one for renaming stuff away from spdy, as well.
Assignee: VYV03354 → hurley
Flags: needinfo?(hurley)
(Assignee)

Updated

3 years ago
Depends on: 1287132
Whiteboard: [necko-active]
(Assignee)

Updated

3 years ago
Attachment #8719237 - Attachment is obsolete: true
(Assignee)

Comment 10

3 years ago
Comment 9 is the patch ready to go. Try run at https://treeherder.mozilla.org/#/jobs?repo=try&revision=91ebf7b76273

Patrick, feel free to review whenever, I won't land until the 51 cycle starts on Aug 5.
I guess this is good training for watching my kid leave the house and go off to the real world. bittersweet.

r+ for 51
Comment on attachment 8774707 [details]
Bug 1248197 - Remove spdy/3.1 support.

https://reviewboard.mozilla.org/r/67152/#review64070
Attachment #8774707 - Flags: review?(mcmanus) → review+
(Assignee)

Comment 13

3 years ago
Dunno why I typed Aug 5 - the 51 cycle has started as of yesterday!

Comment 14

3 years ago
Pushed by hurley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea3d721baedc
Remove spdy/3.1 support. r=mcmanus

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ea3d721baedc
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.