The default bug view has changed. See this FAQ.

With tabs set to bottom of browser (TMP), top of browser acts like title bar when double clicked

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Adrian Sampaleanu, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8719244 [details]
double-clickable, titlebar-zone.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160213030210

Steps to reproduce:

Add the Tabmix Plus extension. Set the tab bar to be multi-row (easier to notice effect) and at the bottom of the browser. Open up enough tabs to create three rows of tabs (again, it's easier to see effect with a wider region).

Navigate to any page. Double click at the top of the browser on an area with no active controls), below the address bar and within a horizontal strip that is as tall as the bottom row of tabs. 


Actual results:

The browser switches between a maximized state and the restored state.


Expected results:

Nothing should have happened if the double click was over an area with no active controls. If the problem of the treatment of this area as a title bar was restricted to areas with no active navigational features, it wouldn't be too bad. The problem is that it happens even _if_ there are controls, rendering them non-active. I've included a screenshot of the top of a GMail page where I've indicated in yellow the area where double-clicks toggle the window state. The buttons that fall in that region do not work, if they are simple controls like the send to trash, or the mark as spam buttons, for example.

I've checked this in 46.0a2 and the issue is not present there, so this is a regression.
Should be reported to the extension's developer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 2

a year ago
This bug seems somewhat similar to [bug 575248](https://bugzilla.mozilla.org/show_bug.cgi?id=575248).

Comment 3

a year ago
I can reproduce in 47.0a1 (2016-02-13).
Has STR: --- → yes
Component: Untriaged → Extension Compatibility
Summary: With tabs set to bottom of browser, top of browser acts like title bar when double clicked → With tabs set to bottom of browser (TMP), top of browser acts like title bar when double clicked
You need to log in before you can comment on or make changes to this bug.