Closed Bug 1248227 Opened 6 years ago Closed 2 years ago

[css-grid] Assertion failure in nsGridContainerFrame::TrackSizingFunctions::TrackSizingFunctions (with 'subgrid' pref enabled)

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox47 --- affected

People

(Reporter: jruderman, Assigned: mats)

References

(Blocks 3 open bugs)

Details

(Keywords: assertion, testcase)

Attachments

(3 files)

Attached file testcase
With:
  user_pref("layout.css.grid-template-subgrid-value.enabled", true);

Assertion failure: !mHasRepeatAuto || (mMinSizingFunctions.Length() >= 1 && mRepeatAutoStart < mMinSizingFunctions.Length()), at layout/generic/nsGridContainerFrame.cpp:392
Attached file stack
Attachment #8719247 - Attachment description: q.html → testcase
Blocks: 1240834
Priority: -- → P5
Summary: Assertion failure in nsGridContainerFrame::TrackSizingFunctions::TrackSizingFunctions → Assertion failure in nsGridContainerFrame::TrackSizingFunctions::TrackSizingFunctions (with 'subgrid' pref enabled)
Summary: Assertion failure in nsGridContainerFrame::TrackSizingFunctions::TrackSizingFunctions (with 'subgrid' pref enabled) → [css-grid] Assertion failure in nsGridContainerFrame::TrackSizingFunctions::TrackSizingFunctions (with 'subgrid' pref enabled)
Duplicate of this bug: 1267105
Duplicate of this bug: 1267132
Blocks: css-grid-2

The testcase no longer triggers an assertion.

Assignee: nobody → mats
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Duplicate of this bug: 1324493
You need to log in before you can comment on or make changes to this bug.