Closed Bug 1248622 Opened 5 years ago Closed 4 years ago

Investigate empty arrays reported as empty objects

Categories

(Toolkit :: Telemetry, defect, P3)

defect
Points:
3

Tracking

()

RESOLVED DUPLICATE of bug 1323964
Tracking Status
firefox47 --- affected

People

(Reporter: Dexter, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [measurement:client])

(In reply to Georg Fritzsche [:gfritzsche] from bug 1243893 comment #16)
> (In reply to Alessio Placitelli [:Dexter] from bug 1243893 comment #13)
> > ...
> > * partnerNames is an object when empty, an array when non-empty
> ...
> > * system/gfx/monitors is an object when empty, an array when non-empty
> > * payload/UIMeasurements can be an empty object (and maybe an empty array)
> > * payload/threadHangStats can be an empty object (and maybe an empty array)
> > ...
> > * environment/addons/activePlugins can be an empty object instead of an
> > array.
> > * environment/addons/activePlugins/[i]/mimeTypes can be an empty object
> > instead of an array
> 
> This seems to be a common pattern - we should nail down whether this:
> a) is a current problem
> b) happening on the client or an artifact of the analysis
Points: --- → 3
Priority: -- → P3
Whiteboard: [measurement:client]
Priority: P3 → P2
Priority: P2 → P3
This is likely to be bug 1323964.
Depends on: 1323964
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323964
You need to log in before you can comment on or make changes to this bug.