Closed Bug 1248693 Opened 7 years ago Closed 7 years ago

install.rdf addon version is wrong

Categories

(Firefox :: Pocket, defect)

46 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 47
Tracking Status
firefox46 + fixed
firefox47 + fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

Details

Attachments

(1 file)

It currently uses the firefox version for the addon version.  This should be different to allow the potential for future out of band updates to the addon.
[Tracking Requested - why for this release]:  see comment 0
Blocks: 1215694
Tracking for 46 since this is feature related work aimed at 46. Thanks Shane!
Assignee: nobody → mixedpuppy
Attachment #8719899 - Flags: review?(gijskruitbosch+bugs)
Attachment #8719899 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/99b0afb72e77
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Comment on attachment 8719899 [details] [diff] [review]
fix addon version

Approval Request Comment
[Feature/regressing bug #]:pocket
[User impact if declined]:incorrect version would affect out of band updates if they were to happen
[Describe test coverage new/current, TreeHerder]:none
[Risks and why]: low
[String/UUID change made/needed]:none
Attachment #8719899 - Flags: approval-mozilla-aurora?
Comment on attachment 8719899 [details] [diff] [review]
fix addon version

Needed for pocket to work as system addon in 46. Please uplift to aurora.
Attachment #8719899 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
[bugday-20160323]

Status: RESOLVED,FIXED -> UNVERIFIED

Comments:
STR: Not clear.
Developer specific testing

Component: 
Name			Firefox
Version			46.0b9
Build ID		20160322075646
Update Channel          beta
User Agent		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS			Windows 7 SP1 x86_64

Expected Results: 
Developer specific testing

Actual Results: 
As expected
You need to log in before you can comment on or make changes to this bug.