Website causes Firefox to hang with 100% CPU usage, at mozilla::StyleAnimationValue::ExtractComputedValue

RESOLVED DUPLICATE of bug 1245260

Status

()

RESOLVED DUPLICATE of bug 1245260
3 years ago
3 years ago

People

(Reporter: Felipe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8720267 [details]
sample-history-channel.txt

Visiting this website will cause Firefox to hang forever. Happens both on e10s (hanging the content process) or non-e10s. The stack has a lot of stuff, but I noticed many instances of mozilla::StyleAnimationValue::ExtractComputedValue and other animation-related functions, so filing it here.

I only tested it on OSX Yosemite, latest nightly. Happens on a clean profile

Note: this will hang the browser
http://www.history.com/shows/join-or-die-with-craig-ferguson
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245260
You need to log in before you can comment on or make changes to this bug.