All users were logged out of Bugzilla on October 13th, 2018

PDF document is not opened in sidebar

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: vasilica.mihasca, Assigned: Snuffleupagus)

Tracking

({regression})

Trunk
Firefox 47
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 wontfix, firefox45 wontfix, firefox46 wontfix, firefox47 verified)

Details

(Whiteboard: [pdfjs-c-ff-integration][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7007)

[Affected versions]:
Firefox 44.0.2
Firefox 45 Beta 6 
Firefox 46.0a2 (2016-02-16)
Firefox 47.0a1 (2016-02-16)

[Affected platforms]:
Ubuntu 12.04 64-bit
Mac 10.10.5
Windows 10 32-bit

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Bookmark a pdf file (e.g http://cp.literature.agilent.com/litweb/pdf/5989-8139EN.pdf )
3.Right click on bookmark and select Properties.
4.Check “Load this bookmark in the sidebar” checkbox and click “Save” button.
5.Click on bookmark in order to open it in sidebar.

[Expected Results]:
The Pdf file is successfully opened in sidebar.


[Actual Results]:
- The Pdf file is continuously loading. See screenshot: http://i.imgur.com/ihYCT9y.png
- The following error is thrown in Browser Console: TypeError: window.gBrowser is null browser.js:135:3 
- The Pdf document is successfully displayed after clicking on “Stop loading this page” button from context menu.


[Additional notes]:
This issue is also reproducible on Firefox 37.0a1 (2014-12-01)
Investigated further and noticed that this issue is a regression:

- Last good revision: dac5700acf8b (2012-10-17)
- First bad revision: cb573b9307e5 (2012-10-18)
- Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dac5700acf8b&tochange=cb573b9307e5


- I suspect that this issue is regressed by Bug 801280
Blocks: 801280
Flags: needinfo?(ryanvm)
Keywords: regression
I just landed the upstream update - redirecting to bdahl for investigation.
Flags: needinfo?(ryanvm) → needinfo?(bdahl)
(Assignee)

Comment 3

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #2)
> I just landed the upstream update - redirecting to bdahl for investigation.

Earlier today I submitted https://github.com/mozilla/pdf.js/pull/7007, which is currently pending review.
Depends on: 1249508
(Assignee)

Updated

3 years ago
Assignee: nobody → jonas.jenwald
Flags: needinfo?(bdahl)
Whiteboard: [pdfjs-c-ff-integration][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7007
This should be fixed in tomorrow's nightlies. Not sure this is severe enough to warrant worrying about backporting to 45/46, though.
status-firefox44: affected → wontfix
Flags: needinfo?(vasilica.mihasca)
Confirm that this issue is fixed on latest Firefox 47.0a1 (2016-02-21) under Windows 10 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.
status-firefox47: affected → verified
Flags: needinfo?(vasilica.mihasca)

Comment 6

3 years ago
Since this is in nightly, can the right owner mark it FIXED? I agree this is not a candidate for uplift.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Depends on: 1251620
No longer depends on: 1251620
You need to log in before you can comment on or make changes to this bug.