Closed Bug 1249015 Opened 4 years ago Closed 4 years ago

Context is still updated in standalone when sharing is stopped

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox46 affected, firefox47 affected)

RESOLVED FIXED
Iteration:
47.2 - Feb 22
Tracking Status
firefox46 --- affected
firefox47 --- affected

People

(Reporter: bogdan_maris, Assigned: Mardak)

Details

Attachments

(1 file)

[Affected versions]:
- Latest Aurora 46.0a1
- Latest Nightly 47.0a1

[Affected platforms]:
- Mac OS X 10.10.5
- Ubuntu 14.04 32-bit

[Steps to reproduce]:
1. Start Firefox
2. Install the latest Hello add-on (1.1.2 at this moment)
3. Change the loop.server to https://loop-dev.stage.mozaws.net/v0 in about:config
4. Restart Firefox
5. Start a conversation
6. Join the conversation from another browser/PC
7. Click Stop Sharing on the PC the call was started
8. Switch tabs (make sure tabs contain websites and not about: pages)

[Expected result]:
- Context is not updated in Standalone, only chat can be still used.

[Actual result]:
- Context is updated in Standalone when switching tabs on the first PC.

[Regression range]:
- Not a regression, it reproduces since fix from bug 1215612 was pushed in Standalone.

[Additional notes]:
- Unable to check on Firefox Beta or Release due to the incompatibility of the add-on with 45 or 44 (at this moment)
Rank: 5
Priority: -- → P1
Should probably be able to do something similar to not sending pointer events:

https://github.com/mozilla/loop/pull/134/files#diff-5addb23a0c0fbd56768583e5283792adR662

But from _notifyBrowserSwitch perhaps?
Ah perhaps not that easy as we still need to let the sdk know the tab changed.. Next simplest might be to pass the paused state to _handleSwitchBrowserShare as well as the window id?
Also tested on Windows 10 64-bit, same result (also affected).
Assignee: nobody → edilee
Attachment #8720704 - Flags: review?(b.mcb)
Comment on attachment 8720704 [details] [review]
[loop] Mardak:bug-1249015-pause-context > mozilla:master

Looks good to me! r=me with nit addressed

Thank you
Attachment #8720704 - Flags: review?(b.mcb) → review+
https://github.com/mozilla/loop/commit/5f94d79b5fb7d820c8bda195e09f710ec32c703a
Status: NEW → RESOLVED
Iteration: --- → 47.2 - Feb 22
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.