Make bdo element use unicode-bidi: isolate-override

RESOLVED FIXED in Firefox 50

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

({dev-doc-complete})

unspecified
mozilla50
dev-doc-complete
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
In bug 1218706, we applied "unicode-bidi: isolate" too all elements with dir attribute except bdo.

bdo needs "isolate-override", which we haven't fully supported yet, but once we finish that, we should change its default value.
What's missing in isolate-override support? I added it (prefixed) in bug 774335, and it's already used in html.css for bdo[dir="auto"]
(Assignee)

Comment 2

3 years ago
Ah, I didn't notice it is already there for bdo[dir="auto"]. Then I guess we should make it the default for "bdo, bdo[dir]" directly.

The issue is that, we are still failing tests of isolate-override from CSSWG. It can be seen here: [1]. I compiled a build with unprefixed unicode-bidi values, and ran through the test suite, so the tests in this list which has one "passed" but lots of "failed" are likely due to that.

The tests with absolutely no "passed" are the problems we have. So it's bidi-isolate-override-005 ~ 010 for isolate-override.


[1] https://test.csswg.org/harness/results/css-writing-modes-3_dev/grouped/section/2/
Keywords: dev-doc-needed
(Assignee)

Updated

3 years ago
Summary: Make unicode-bidi: isolate-override to bdo by default → Make bdo element use unicode-bidi: isolate-override
(Assignee)

Comment 3

3 years ago
Created attachment 8767084 [details]
Bug 1249497 - Use isolate-override for bdo elements.

Review commit: https://reviewboard.mozilla.org/r/61788/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/61788/
Attachment #8767084 - Flags: review?(jfkthame)
Attachment #8767084 - Flags: review?(jfkthame) → review+
(Assignee)

Updated

3 years ago
Assignee: nobody → xidorn+moz

Comment 5

3 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d42940726072
Use isolate-override for bdo elements. r=jfkthame

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d42940726072
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Added an info in:
https://developer.mozilla.org/en-US/Firefox/Releases/50#HTML

I don't think it is worth a mention on the element page itself.
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.