Closed Bug 12499 Opened 21 years ago Closed 20 years ago

Running apprunner -installer shows no UI

Categories

(Core Graveyard :: Profile: Migration, enhancement, P3)

x86
Windows NT
enhancement

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssu0262, Assigned: dbragg)

References

Details

I ran apprunner -installer on my NT box and it took a long time to startup.  Don
Bragg indicated to me that if there's only one profile to migrate, it won't show
UI letting the user know what is happening.

This is bad!  There needs to be some kind of UI letting the user know what is
(preferably a message box) happening, maybe even a way to cancel out of it.
Assignee: selmer → kevinyen
Since the -installer flag is only used when the installer launches the app to do
migration, I don't see a compelling need for a message box.  If the migration is
the cause of the delay, the existing plans for a progress dialog should
suffice.  A dialog that attempts to explain migration will only cause extra
confusion in the majority of cases.

Kevin, what do you think?  Do you want a dialog to inform people we've migrated
their profile before they enter activation?
Severity: major → enhancement
Target Milestone: M15
The progress bar (with appropriate text in teh dialog) should suffice.  No
additional dialog needed.

Migrating existing info is a normal and expected part of the upgrade process for
nearly all mainstream software.

thx,
kevin
Assignee: kevinyen → dbragg
Don, do we have progress dialogs during migration yet?
Component: Profile Manager → Profile Migration
Status: NEW → ASSIGNED
Depends on: 11282
This bug depends on bug 11282 which is the bug to add a progress dialog to the
profile migration.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Oh yeah.  This is fixed.  I lost track of dependencies or whatever.  The
progressbar is in.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.