Closed Bug 125009 Opened 23 years ago Closed 21 years ago

DND bookmarks from SmartFind bookmarks: refresh problem in a specific case

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: p_ch, Assigned: p_ch)

References

Details

Linux build 2002 02 08 21

Step to reproduce:
- open the "Bookmarkmark URL containning '.org'" folder (in the Mozilla
Project>Technology demonstration>Smart Find queries folder".
- DND an item from this folder just above the last separator in the bookmark list
- Delete the copied item (since SmartFind is dynamically created, copy is fine)

Expected: the copy is deleted
Actual  : need to refresh to see it deleted.

Comment: if the "smartfind bookmark" is dropped above the Technology
Demonstration folder, the outliner is correctly refreshed after its deletion.
Works for me 2002030103 on WInXP.

Pierre, are you still seeing this on a recent build?
Well with linux build 2002 02 28 08, and a fresh profile,
I just can't delete the copy of the smart find bookmark...
And copying again this copy and deleting the new bookmark will lead to a blank
bookmark !
Strange!
I can confirm this (all instructions followed from Bookmarks->Manage Bookmarks
(Ctrl-B)) Version 1.0rc1 on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
taking
Assignee: ben → chanial
Depends on: 160019
Works on Win2k.

pch: you know probably best if this still does/can happen - after all you filed
this bug and rewrote bookmarks...
this bug has been fixed by the bookmark rewrite but then the 'find' queries have
been broken since part2.
Not sure what to do with this bug :)
Resolving as fixed by the bookmarks rewrite.

pch: what you mean is probably bug 200136. And even if not this one here should
not be morphed IMO. It was a different problem and there are enough bug numbers
available for many years, no shortage in sight... :-)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.