Closed Bug 1250091 Opened 9 years ago Closed 8 years ago

A blank page is displayed if the Firefox is restarted while the RDM is enabled

Categories

(DevTools :: Responsive Design Mode, defect, P1)

47 Branch
defect

Tracking

(firefox44 unaffected, firefox45 unaffected, firefox46 unaffected, firefox47 affected, firefox51 verified)

VERIFIED FIXED
Iteration:
51.2 - Aug 29
Tracking Status
firefox44 --- unaffected
firefox45 --- unaffected
firefox46 --- unaffected
firefox47 --- affected
firefox51 --- verified

People

(Reporter: mboldan, Assigned: jryans)

References

Details

(Whiteboard: [multiviewport] [reserve-rdm])

[Affected versions]:
- Firefox 47.0a1 (2016-02-21)

[Affected platforms]:
- WIndows 10 x86, Ubuntu 12.04 x64, Mac OS X 10.9.5

[Steps to reproduce]:
1. Launch Firefox.
2. From about:config, enable the devtools.responsive.html.enabled pref.
3. Open RDM.
4. Restart the browser by using the 'restart' command in the Developer Toolbar. 

[Expected result]:
After restart, the RDM page is opened, displaying the content of the opened page.

[Actual result]:
The RDM is closed and a blank page is displayed.

[Regression range]:
- This is not a regression since this is a new implementation.

[Additional notes]:
- If the RDM is opened, the content of it is also blank. Only after closing the RDM, the page is loaded.
Whiteboard: [multiviewport] → [multiviewport] [triage]
This may get resolved as part of bug 1240900.
Depends on: 1240900
Priority: -- → P3
Whiteboard: [multiviewport] [triage] → [multiviewport]
Priority: P3 → P2
Whiteboard: [multiviewport] → [multiviewport] [mvp-rdm]
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
This issue is also reproducible if at step 4 the page is refreshed (F5) instead of restarted.
Priority: P2 → P3
Whiteboard: [multiviewport] [mvp-rdm] → [multiviewport] [reserve-rdm]
This issue is fixed.  It doesn't reopen RDM on restart, but the page content itself is restored, which seems fine to me (and might even be preferable to opening RDM again).
Assignee: nobody → jryans
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Iteration: --- → 51.2 - Aug 29
Priority: P3 → P1
I managed to test this issue on Firefox 51.0a1 (2016-08-23) under Windows 10 x64, Mac OS X 10.9.5 and under Ubuntu 16.04 x64 and came to the following conclusion:
- the page is correctly refreshed when using the F5 key from the keyboard, or when using the refresh button from the URL bar.
- the RDM is disabled and the page is correctly displayed if the page is restarted from the Developer Toolbar and after restarting the page, the RDM can reopened.

But I noticed that the Developer Toolbar is no longer displayed after the page is restarted from the Developer Toolbar while the RDM is enabled. 
Note that in the Menu->Developer, the Developer Toolbar tool appears to be enabled. Also nothing happens if the Developer Toolbar button is clicked or if the Shift+F2 command is used.

Should I log a different bug for the issue described above?
QA Whiteboard: [qe-rdm]
Flags: needinfo?(jryans)
(In reply to Mihai Boldan, QA [:mboldan] from comment #4)
> But I noticed that the Developer Toolbar is no longer displayed after the
> page is restarted from the Developer Toolbar while the RDM is enabled. 
> Note that in the Menu->Developer, the Developer Toolbar tool appears to be
> enabled. Also nothing happens if the Developer Toolbar button is clicked or
> if the Shift+F2 command is used.
> 
> Should I log a different bug for the issue described above?

Can you provide more details here?  I wasn't able to reproduce so far.  Here's what I tried:

0. Developer Toolbar is disabled (not shown) at the start
1. Open some page, I used https://www.mozilla.org/en-US/?v=b.
2. Open the new RDM tool
3. Open Developer Toolbar
4. Enter "restart" in the toolbar to restart Firefox

The page appears (RDM is closed as expected) and the Developer Toolbar is also shown at the bottom of the window.
Flags: needinfo?(jryans) → needinfo?(mihai.boldan)
The issue is reproducible using the next STR:

1. Launch Firefox.
2. From about:config, enable the devtools.responsive.html.enabled pref.
3. Open Developer Toolbar and restart the browser using the restart command.
4. Select one of the already opened tabs.
5. Enable RDM.
6. Restart the browser using the 'restart' command in the Developer Toolbar.

Actual result:
The browser is restarted and the Developer toolbar is no longer displayed and in Menu->Developer, the Developer Toolbar is checked, as it is enabled.

Here is a screencast with the issue: https://drive.google.com/open?id=0B-cUbHVNThEKZjhmRFBlRmQ5Tnc

Please let me know if I can help you with any other information.
Flags: needinfo?(mihai.boldan) → needinfo?(jryans)
(In reply to Mihai Boldan, QA [:mboldan] from comment #6)
> The issue is reproducible using the next STR:
> 
> 1. Launch Firefox.
> 2. From about:config, enable the devtools.responsive.html.enabled pref.
> 3. Open Developer Toolbar and restart the browser using the restart command.
> 4. Select one of the already opened tabs.
> 5. Enable RDM.
> 6. Restart the browser using the 'restart' command in the Developer Toolbar.
> 
> Actual result:
> The browser is restarted and the Developer toolbar is no longer displayed
> and in Menu->Developer, the Developer Toolbar is checked, as it is enabled.
> 
> Here is a screencast with the issue:
> https://drive.google.com/open?id=0B-cUbHVNThEKZjhmRFBlRmQ5Tnc
> 
> Please let me know if I can help you with any other information.

Hmm, curious!  I still can't seem to replicate.  I tried on OS X 10.11 and Windows 10.  In any case, let's file a bug to track this issue, and we can try to work out what's different between my setup and yours over there.

Thanks for testing!
Flags: needinfo?(jryans)
Since the found issue was logged separately as Bug 1298811, I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.