[PRINTING] when printing HTML with frames, or XUL with iframes, only the bottom frame gets printed.

VERIFIED DUPLICATE of bug 7201

Status

()

Core
Printing: Output
P3
blocker
VERIFIED DUPLICATE of bug 7201
19 years ago
19 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: dcone (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

if you load the following html, and try to print it, only the bottom frame will
get printed.

<html>
<head>
<title>A</title>
</head>
<frameset rows="*,*">
<frame src="http://www.yahoo.com">
<frame src="http://www.netscape.com">
</frameset>
</html>

I bet this bug is cross platform, but I haven't tried on Mac on Windows yet, so
I'm marking Linux.
Summary: [PRINTING] when printing frames, only the bottom frame gets printed. → [PRINTING] when printing HTML with frames, or XUL with iframes, only the bottom frame gets printed.
Another test case, involving XUL:

<?xml version="1.0"?>
<window xmlns:html="http://www.w3.org/TR/REC-html40"
                xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only
.xul">
<html:iframe src="http://www.yahoo.com" />
<html:iframe src="http://www.mozilla.org" />
</window>

Only the bottom iframe gets printed.  This preventing me from (correctly)
printing an email message, as our message display is:

<window>
<toolbox>
	<toolbar>
	</toolbar>
	<toolbar>
	</toolbar>
</toolbox>
<html:iframe>
</window>

Comment 2

19 years ago
petersen, is this Linux only, or all platforms?

Updated

19 years ago
Severity: normal → blocker

Comment 3

19 years ago
Upgrading severity to blocker since the current mail/news UI relies on this
working, so if it's not going to work, we need to know.
(Assignee)

Updated

19 years ago
Depends on: 7201
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
No longer depends on: 7201
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
This is kind of a duplicate -- The issue it that we print all the frames (leaf
frames), not everything neccisarily gets loaded some some frames will come out
blank.  We are waiting for the Webshell to get a hook into the currently in
focus Webshell so that only this one will be printed.  Joki has this bug
currently and will be passed back to me to hook up the currently infocus Frame.


*** This bug has been marked as a duplicate of 7201 ***

Comment 5

19 years ago
So if only one frame is printed, this would mean that if the message headers are in a different frame than the body, we'd get one or the other frame, but not both? If so, is it possible to make the policy decision to print more than one frame?

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Based on don's comments, marking as verified duplicate of 7201.
You need to log in before you can comment on or make changes to this bug.